Showing results for 
Search instead for 
Do you mean 
Reply
Geri Krista
Posts: 2
Registered: ‎04-23-2012

Smart Phone won't connect to WiFi router WRT54GS - Can you help?

I connected my router to a new computer. The computer is connected to the Internet.

My SmartPhone won't connect via the router.

 

Details of problem:

 

  • I logged in to the router from my cell and entered the password.
  • The cell says the following over and over without connecting:
  1. Scanning
  2. Obtaining IP address from router
  3. Disconnected
  4. Connecting
  5. Scanning ... over & over

How can I connect my Samsung GAlaxy SII Skyrocket to my WiFi router [WRT54GS]?

 

Thank you.  :^)

vai_fan
Posts: 2,766
Registered: ‎09-07-2006

Re: Smart Phone won't connect to WiFi router WRT54GS - Can you help?

For most issues concerning wireless-N routers, the quickest and easiest workaround would be to powercycle the device.  To do this, power OFF the router by unplugging the power cord and wait for 10 seconds before plugging it back in. Here is the link if unable to connect wirelessly with an Android smartphone: http://www6.nohold.net/Cisco2/ukp.aspx?pid=93&login=1&vw=1&app=search&articleid=25337&userrole=Links...

VALETLINKSYS
Posts: 438
Registered: ‎10-16-2011

Re: Smart Phone won't connect to WiFi router WRT54GS - Can you help?

Got that issue before , What I did was

 

  • I removed my network name that was being remembered by the phone
  • Try to connect again

or you can change the wireless channel





I believe that I can make it :smileyhappy:
debi4ppl
Posts: 1
Registered: ‎08-21-2013

Re: Smart Phone won't connect to WiFi router WRT54GS - Can you help?

tried the link offered & secured & no credentials to get there! My phone dies same. I can log in to modify settings & password works. Shows signal is strong. When searching for IP address it pops up with disconnecting, signal to weak. For over a year it's been fine with my Samsung galaxy III. Sprint says phone is fine. They tested wireless & worked fine with their's. Unplugging router to reset did not help. Any ideas? I don't want to mess up settings in router by trial n error! Laptops attach fine!
meica1013
Posts: 38
Registered: ‎08-14-2013

Re: Smart Phone won't connect to WiFi router WRT54GS - Can you help?

Hi. Try to adjust the channel on your router’s wireless settings. It is good to specify such instead of auto mode. Check also if you have WPA2/WPA mixed mode Security type. Or you can use specifically WPA2 Personal but it depends on your other devices too if they are capable of connecting to that security type. If not, you can use WPA Personal with the same security key of course. Turn off/on your router after that. Do make sure also you have the latest firmware of your router.
dallascowboys1
Posts: 118
Registered: ‎11-22-2006

Re: Smart Phone won't connect to WiFi router WRT54GS - Can you help?

[ Edited ]

It is always best to disable security and verify that your phone can connect first. Then apply security to verfy which type of security works with your phone. As was stated your phone may not support WPA2 and you would also need to set your router to mixed mode rather then just N only.

 

____________________________
Linksys E4200 Ver.1.0.05 (Build 7)

ArthurRenzo
Posts: 181
Registered: ‎08-01-2013

Re: Smart Phone won't connect to WiFi router WRT54GS - Can you help?

Please try to make sure that the Wireless MAC Filter is disabled on your router, since this is one of the probable cause of your concern. It is useful to remove the saved/remembered networks from your smart phone, forcing it to establish a connection with the nearest router with the strongest signal strength. You can create a wireless profile on your smart phone for your router’s wireless network.

 If the other wireless devices can connect to your router’s wireless network and the smart phone is the only one having an issue then there might be something wrong with the smart phone. Try to check if setting static IP address on the phone will help to further isolate the issue.