Posts: 28
Registered: ‎05-30-2007

Solution: WRT160n as switch & access point (when there's another main router)

My home network is basically this:

CABLE MODEM -> WIRED ROUTER -> WIRELESS ROUTER configured as switch. [1]

I changed our wired router to a different one, and then discovered I couldn't talk to our wireless router. To fix this I had to reset the wireless router back to factory settings so it would talk to me, and then set all the wireless router settings back to what they were.

I'm documenting the steps here in case they are helpful to others.

Our wireless router is a Linksys WRT160n. It's configured to act as a switch instead of a router, since we already have a wired router doing the "routing".

All further references to "router" refer to our Linksys WRT160n wireless router. If I refer to our wired router I will say "wired router".

(Some steps below may not be necessary. I don't have time to do tests to determine if some steps can be skipped, or if the order can be changed. Many steps have footnotes where I give a more thorough explanation in case someone isn't sure what I'm talking about.)

  1. Reset Wireless Router
    1. Shutdown all computers
    2. Unplug power to router
    3. Unplug all ethernet cables to router
    4. power up router
    5. press and hold router reset button for 10 seconds [2]

  2. Connect a Computer to the Router
    1. Shutdown computer
    2. Plug an ethernet cable from computer to port 1 of router. [3]
    3. Boot computer. Let it boot all the way
    4. Plug in power to router
    5. Hopefully after a minute or so computer discovers router and displays a message asking if this is a public or private network. (Select private)

  3. Set Router Settings:
    1. In a web browser go to [4][5]
    2. User Name: <blank>
      Password: admin
      1. IP Address: [6]
      2. DHCP Server Settings: Disabled
      3. Time Settings: <:your time zone>:
      4. Save Settings [7]

    4. (My web browser automatically reconnected to the router using the router's new IP address of . I've no idea how the router/computer managed to do that. If you don't get automatically reconnected, then manually go to

      1. Wireless Configuration: Manual
      2. Network Name: <anything you want to call it.> [8]
      3. Save Settings

      1. Security Mode: WPA2 Personal
      2. Encryption: AES [9]
      3. Passphrase: <make up a password here> [10]
      4. Save Settings

      1. check that SPI Firewall Protection: Enabled

  4. On Vista Computers make sure "Network Discovery" is switched on:
    2. Check that is says "Network(Private network)" [11]
    3. Under "Sharing and Discovery"
      1. Network discovery: On
      2. File sharing: On
      3. Public folder sharing: On
      4. Printer Sharing: On [12]
      5. Password protected sharing: Off [13]
      6. Media sharing: Off [14]

  5. Now get the home network up and running.
    1. Shutdown all computers
    2. Power off both router and wired router
    3. Connect a computer to the wired router
    4. Power up wired router.
    5. Boot computer all the way. Wait for computer to fully boot. (This ensures the computer will make itself the Browser Master since there are no other computers.) [15]
    6. Test internet access [16]
    7. Connect wired router to wireless router
      1. Connect port 1 of wired router to port 1 of wireless router. [17]
    8. Connect all your other wired computers to the network
    9. Boot all the other computers (both wired and wireless)
    10. Check for internet access on other computers

  6. Wait 48 minutes for network browsing to start working.
    Somewhere I read it can take up to 48 minutes for the computers to find each other so they all show up under "My Networks". During this time you should be able to connect to a remote computer if you explicitly give the name of the remote computer. This is because network "Name Resolution" and "Browsing the network" are two separate things.

    "Name resolution and browsing the network would seem to be closely related. If you can resolve all of the names on a network, then you should be able to browse the network. While this appears on the surface to be true, it is not. The mechanism for browsing is unrelated to the name resolution process." [18]
    As I understand it, if you already know the name of the remote computer, your computer will ask your main router to translate that name to an IP address, and it can then connect. [19]

    But if you instead open Windows Explorer and go to 'Network' to see what computers are available, your computer asks the Master Browser (what ever computer got the duty of being the Master Browser) for a list of all the computer names. If the Master Browser doesn't yet know the name of a computer that just recently joined the network, then that name won't show up as you browse the network.

    So network browsing may be a problem that will fix itself if you just walk away from it for awhile. [20][21]

[1] The layout of our house and location of the computers around our house pretty much dictate our home network needs to be set up this way with both a wired router and a wireless router configured as a switch.

[2] You'll need something like a pen or paper clip to push and hold the router's reset button.

[3] It may not be necessary to use Port 1. Probably any numbered port will do.

[4] Enter "" (without the quotes) where you would usually enter e.g. i.e. where the website address (also known as the URL) goes. Usually it's the field at the top of the browser.

[5] is for Linksys routers. I saw a D-Link router that used instead.

[6] for a home network. Don't do or you'll end up with two network domains.

[7] At the bottom click the "Save Settings" button. Then click the "Continue" button.

[8] This is the name that will show up when you (or your neighbor) browse for a wireless connection.

[9] I think the other setting, "TKIP or AES", will also work, since it includes AES.

[10] This is the password that prevents your neighbors from connecting to your home network and using your internet connection.

[11] We're looking for the word 'private'. Private for a home network.

[12] Optional. If there is no printer connected directly to this computer then you may leave this off. (e.g a printer connected to a USB port on this computer.)

[13] Optional.

[14] Optional. I found with this set to 'On' Vista did a bunch of time consuming things that were useless and a bit annoying for me, so I just switched this off.

[15] We want to make sure we don't end up with two computers thinking they are both the master browser. If you have browstat.exe installed you can go to a DOS command prompt and run: browstat status . See footnote 21 below for more.

[16] Open a web browser and go somewhere, such as . See if it works.

[17] This is for the case where the wired router is your main router (has DHCP enabled) and the wireless router is just being used as a switch and access point (has DHCP disabled). It may not be necessary to use Port 1. Probably any numbered port will do.

[18] "How NetBIOS name resolution really works" by Robert L. Bogue

[19] The main router has DHCP turned on, and when a new computer connects to the network, the router gets that computer's name and assigns it an IP address (e.g. The router keeps a table of computer names and corresponding IP addresses. You can view this table by logging into your router and searching for it. (e.g. for Linksys BEFSR41 router open a web browser and go to , then go to STATUS -> LOCAL NETWORK and click the button 'DHCP Client Table')

[20] You may wish to disallow certain computers from becoming the Master Browser, such as computers that are frequently disconnected from your network, or slow computers. There's a registry key for that somewhere. But this is advanced.

[21] You may also download and install browstat.exe from Microsoft. This requires first installing .NET version 1.1 (browstat.exe wasn't happy with any other version of .NET . Yes you can have more than one version of .NET installed at the same time.)

Then at a DOS command prompt enter: browstat status

Note that error "Could not connect to registry, error = 53" is normal for a home network. Only Windows XP pro can connect to a remote registry, and probably some business version of Vista. It's not important.

And here's a superb website with networking troubleshooting info:
PChuck's Network: Microsoft Windows Networking, Security, and Support

Posts: 191
Registered: ‎08-16-2008

Re: Solution: WRT160n as switch & access point (when there's another main router)

Its really Appreciable !!!
"What u Give , is wht u better start expecting to take back".. -
Posts: 1
Registered: ‎02-07-2012

Re: Solution: WRT160n as switch & access point (when there's another main router)

[ Edited ]
I think the other setting, "TKIP or AES", will also work, since it includes AES. ----------------------------------------------------------- cheapest hosting
[url=]Cheapest Hosting[/url]