Posts: 2
Registered: ‎11-06-2009

Unable to Access Router Admin Page

[ Edited ]

So I have a weird situation where my router is working fine to allow me access to the internet, yet I am unable to access the router administration page, This occurred after the router froze up tuesday. I reset the router to factory defaults and have since been able to get online, but not access admin page.


Router is a Linksys WRT-54GS V 7
Modem is motorolla SB1505
ISP is earthlink, but in NYC so its actually off the Road Runner network. Cable connection obviously.


- I attempted to access with both Mozilla Firefox and IE 8. FIrefox gives an "Unable to connect" error message. IE 8 redirects me to search engine results (yahoo in this case).
-Ipconfig confirms default gateway and DHCP server is, subnet mask
- I am able to ping the router with <1ms times.
- I have tried resetting router to defaults again, but same issue occurs.
- I am able to get online and access web pages, etc.
- Tried resetting up the router using the Linksys setup program, but it error every time saying "please connect router for broadband"
- Router worked fine with me able to access admin page until it froze up yesterday.
- Wireless works fine. Though the network is unsecure atm, since I can't access router admin.
-  I've also tried disconnecting all other devices from the router except my computer and modem. Still wont let me access router.


System is running windows 7 PRO, fully updated. However, I can't access the router either on 2 other computers at home which run windows XP PRO SP3.


System Specs


CPU: Intel i5 running at stock speeds
Mobo: Gigabyte P55-UD4P
Ram: Gskill Ripjaw, 4 gb DDR3-1600 7-7-7-21
HD: Intel X-25 M 80 gb G2.
PSU: Corsair CMPSU 750 TX
GPU: Diamond ATI 5850


Anyone have any ideas on whats wrong here? Did i miss something obvious? Would greatly appreciate any help as having an unsecure wireless network in the middle of NY isn't the best idea.



Message Edited by Banthracis on 11-06-2009 04:25 PM
Posts: 1
Registered: ‎11-06-2009

Re: Unable to Access Router Admin Page

I have the same Issue, and have done similar steps to correct it yet it still doesn't work..I wanted to access the page to port forwarding.  Software and firmware are up to date.
Posts: 2,766
Registered: ‎09-07-2006

Re: Unable to Access Router Admin Page

As you are Unable to access the setup page on your computer. And it directs you to the Search Engine websites. Well you can try some of these tricks and it should allow you to access the setup page of your Router..


When you Open IE on your computer, First Delete the Browser Settings of your IE (Delete Cookies, Delete Offline Files, Delete Temp Files), and then Disable the Firewall and Antivirus on your computer. 


Now on your computer Click on Start - RUN - and in the Run box type "iexplorer" or type "" (Without Quotes) and click Ok and check if it prompts you for the Username and Password. 

Posts: 2
Registered: ‎11-06-2009

Re: Unable to Access Router Admin Page

It only directs to search engine results with IE 8. As i said in my post, any attempt using Firefox gives the "unable to connect" error. This was done with 3 computers, as I already mentioned. The problem has nothing to do witht he browser, and is an error of some sort in the router itself, as the network works fine and  I could access router admin when i borrowed friends router this afternoon.


Once again I'm looking for a solution to resolve this ROUTER issue, and since I can't access admin, I obviously can't update firmware.  

Posts: 18
Registered: ‎07-09-2007

Re: Unable to Access Router Admin Page

Banthracis there is a way to update the router without going to the web utility pages see my post and response by Klatch here:


as I have the same issue. I can access the internet on all computers and can ping the router.  I can reset my router and gain access to the admin pages for one day and the IP address renew doesnt appear to affect that. My Vista64 machine is hardwired, my XP32bit machine is wireless and I've used the IE7 32bit and 64 bit. Disconnected the internet, deleted browser history, tried Firefox, and several other things.  But I have not updated the router software yet as that seems to cause other problems I'm not ready to deal with unless I cannot figure this out. That will be a last resort. I think this began when I began using Vista 64, though I may be mistaken about that, havent tried to access those pages in awhile. There are no suggestions by Linksys, and I have not yet found a solution in these forums. My router didnt freeze up, though, so the issues may be different. Hope we get solutions soon. BTW my router is WRT110. Cox cable. Arris Voip modem.

Posts: 18
Registered: ‎07-09-2007

Re: Unable to Access Router Admin Page

I have no idea why, but when I installed IE8 I regained access to the Linksys web-based utility pages!  I made no special settings; using medium high settings. 


Hope this helps someone else.


Posts: 18
Registered: ‎07-09-2007

Re: Unable to Access Router Admin Page** revisited July 2010

I am once again unable to access the on-line Router admin page. When I use the EasyLink Advisor and click ADVANCED settings it pulls up the browser but goes nowhere. If I type in the address directly it does the same thing. The address I'm typing is correct. I know because if I unplug the router for a minute, I can get on using the EasyLink or entering the address directly into the browser.  Then I sign in and can access the pages.


Why do I have to keep resetting the router to access the router admin pages? It doesnt matter about virus protection, firewall, what version of Windows I'm using, what browser I'm using...the only thing that matters is resetting the router.


And now I have a new problem.  When I attempt to go online with my new netbook, it causes my wired-to-the-router desktop to loose the connection, even though I reset the router and "added it as a new device".


I was using Homegroup to access the netbook the first day I got it.  Now I cannot access the netbook or the network from the netbook, without resetting the stupid router every single time. I am not using mac address filtering and have the router set to allow 9.


Getting fed up with this router and I never get an answer from Linksys as to why I can never access the router admin pages without resetting the stupid router.

I can get the netbook on other people's wireless networks (using their password) but cannot get onto my OWN using my password.


Does anyone have any ideas?  I'll try anything before yanking this thing out and buying a different brand of router. Yeah I'm mad, sorry.


Wired desktop Windows 7 Home Premium 64/IE8/using Windows firewall and MS Security Essentials. Netbook is W7 Starter, Norton Internet Security 2010. But none of this matters. Because I had the same problem with this router using Vista64, IE7, no firewall, no a/v, IE32 & 64 bit...all those variables yet the only thing that works is resetting the router.

SO WHAT DOES MATTER?  Help me before I trash this thing please.


Posts: 1
Registered: ‎07-15-2015

Re: Unable to Access Router Admin Page** revisited July 2010

Unable access the linksys modem configuration. I wanted to change the IP address of the modem ""  to "" or "" which ever is suitable.


Please guide me rectify it immediately.

Posts: 242
Registered: ‎04-28-2014

Re: Unable to Access Router Admin Page** revisited July 2010

Posts: 1
Registered: ‎02-11-2018

Re: Unable to Access Router Admin Page

this is a big waste of time........ I just need to reset my personal pass word and secure the access.....