Posts: 1
Registered: ‎01-28-2007

Unable to Reset Router

I am using the router WRT54G - 3.0.
I have actually changed my router password previously but have forgotten it. Therefore, now, when i try to upgrade my firmware etc, and they try to detect my router, i am told to key in the password, which unfortunately, i have forgotten.
So, i was told to press the reset button behind, for 15 sec etc. Basically, what happens is, i have tried all the ways to reset my router, but it still doesn't work. As in, i am still prompted for my password. Which is not 'admin' as i have tried that as well.
So, is there any other way i can reset my router? Or is the reset button faulty or something?
Thank you so much.
Posts: 12,649
Registered: ‎07-16-2006

Re: Unable to Reset Router

First: always try this through a wired connection, never through wireless.

Check the manual for your router version for exact instructions how to reset the router. Sometimes it varies a little (maybe you have to press 30s...) The manual is available for download on the linksys website.

If it still does not work, contact linksys support. I would say the reset button is defect then...