Showing results for 
Search instead for 
Do you mean 
Reply
VanillaMozilla
Posts: 12
Registered: ‎06-21-2012

Using WRT54Gl with AT&T U-Verse

I'm trying to use a WRT54GL with U-Verse. The problem is that the router does not get a connection to the modem. It can't ping the modem, and it doesn't show up on on the list of devices connected to the modem. DHCP assigns an IP address of 127.0.0.1, which is outside the range of the modem [192.168.1.1 ... 192.168.1.253]. The router is also showing a default gateway of 0.0.0.0, and a subnet mask of 255.0.0.0. (And yes, I have released and renewed the lease, rebooted the modem, and reconnected the modem.) The router WAN side is set to DHCP, and the operating mode was changed from gateway to router (the gateway setting doesn't work either, for that matter). Any ideas?
Expert
zee29
Posts: 1,329
Registered: ‎04-22-2012

Re: Using WRT54Gl with AT&T U-Verse

There's a possible ip address conflict with your modem and the router. Leave it on Automatic configuration DHCP and change the router ip address to 192.168.2.1.

VanillaMozilla
Posts: 12
Registered: ‎06-21-2012

Re: Using WRT54Gl with AT&T U-Verse

Thanks, that's much better, but there's still a problem. The router can now ping the Internet, and a computer connected to the router can ping the router at either 192.168.2.1 or 192.168.1.72, but the computer cannot ping the modem (192.168.1.254) or beyond. The computer address (192.168.2.100) was set by DHCP on the router. Ifconfig on the computer shows the correct address, yet the computer cannot ping the modem or the Internet. I'm not sure if this is necessary, but I set the router in the DMZ on the modem. However, there's a DMZ light on the modem that's not lit. I restarted the router. Still no Internet connection for the computer. Now what did I miss?
Expert
zee29
Posts: 1,329
Registered: ‎04-22-2012

Re: Using WRT54Gl with AT&T U-Verse

Make sure that the ethernet cable from the AT&T modem is connected to the internet port of the linksys router. Make sure as well that the internet connection type in the linksys router is set to "Automatic Configuration DHCP". After that check in the status page of the linksys router if there is an internet ip address. It should be in the range of your AT&T modem (192.168.1.xxx).

VanillaMozilla
Posts: 12
Registered: ‎06-21-2012

Re: Using WRT54Gl with AT&T U-Verse

Both connections are correct. It depends partly on the starting IP for the router LAN. It was 192.168.2.100, which overlaps with the modem. So I set it to 192.168.2.10. The router IP is now 99.102.13.246 (99.168.2.1 locally). Status page says 99.102.13.246, subnet 255.255.252.0, default gateway 99.102.12.1. The modem shows it at the external address. The router can ping Google. The computer is now 192.168..2.10. It has no Internet connection.
VanillaMozilla
Posts: 12
Registered: ‎06-21-2012

Re: Using WRT54Gl with AT&T U-Verse

Sorry, I meant to say that the cable connection is correct, and the router Internet connection type is Automatic Configuration - DHCP.
jaymay
Posts: 1,830
Registered: ‎04-22-2012

Re: Using WRT54Gl with AT&T U-Verse

Looks like the router is already setup and supposed to work. Since it's still not working, how about you reset the router for 30 seconds, turn it off for 10seconds, once the power light goes solid reconfigure the router again by setting it's IP to 192.168.2.1.

VanillaMozilla
Posts: 12
Registered: ‎06-21-2012

Re: Using WRT54Gl with AT&T U-Verse

I can't do that for a few hours, but in any case, it's curious that it had an internal number (192.168.1.72) but now it has an external number, and the external number is shared with the modem. So something is a little strange.
hiptechboy
Posts: 1,557
Registered: ‎01-03-2011

Re: Using WRT54Gl with AT&T U-Verse

Connect your computer directly to your U-verse gateway, then go to cmd and type in "ipconfig". Look for the default gateway and post it over here. Basically I'll tell you what change your router's IP address to and then after that you'll disable the DHCP server. 

 

What you are currently doing so far is essentially creating two different subnets (networks). Although you can use the internet, your devices on the Linksys router can't communicate with your gateway and anything connected to the gateway. They have to be in the same subnet and only one DHCP server must be enabled. You just have to be careful to not create an IP conflict when choosing the Linksys router's IP address. 

I don't work for Cisco. I'm just here to help.
VanillaMozilla
Posts: 12
Registered: ‎06-21-2012

Re: Using WRT54Gl with AT&T U-Verse

Yeah, I was beginning to wonder. The default gateway is 192.168.1.254. The IP address is 192.168.1.65 and the subnet mask is 255.255.255.0.