Reply
Highlighted
Posts: 3
Registered: ‎06-28-2006

VPN does not work on WRT54G v6

Hi,
 
Just bought a new wireless router (WRT54G v6) to replace my old one who just died after 4 years of loyal services (WRT54G v1) but VPN does not go through even though all the VPN passthrough options are enabled.
 
I'm using a VPN connection created through the Network connection wizard of Windows XP.  This same connection worked fine with my previous router (WRT54G v1) but not with the new one (WRT54G v6).  What can I possibly try to check or do.
 
I also upgraded to the latest firmware 1.00.9 to no avail.
 
Also, if it can help, when I connect my cable modem directly in my computer the VPN goes through.  Through the router, nothing, wired and wireless connections the same.
Posts: 510
Registered: ‎06-28-2006

Re: VPN does not work on WRT54G v6

Are you using a VPN Client software? If so, try to forward the regular VPN ports for it... 47, 50-51, 500 and 1723. On some instances the port can be defined by your network administrator, you should contact them if there are more/different  firewall ports you would need to open. Then enter them into your linksys router page under Applications and Gaming. You should be able to use the software afterwards.
 
Smiley Wink Goodluck!
 
 
"The war between heaven and hell depends on the choices we make, and those choices require sacrifice. That's the test"
Posts: 5
Registered: ‎06-29-2006

Re: VPN does not work on WRT54G v6

I have the same problem with my v5 router. I have forwarded all the ports and updated the firmware but it still will not work. My VPN works everywhere else but at home.
Posts: 17
Registered: ‎06-28-2006

Re: VPN does not work on WRT54G v6

If you have any third party firewall make sure it has been disabled or better to uninstall it. Try also checking for any application that might have been using same port numbers with your VPN.
Posts: 518
Registered: ‎06-29-2006

Re: VPN does not work on WRT54G v6

VPN passthrough enabled?
Regards Simon

NAS: TS-459 Pro - 3.6.1 Build0302T - 4 x 1TB Samsung HD103SJ : EXT4 - APC ES 700VA UPS
QPKG: WordPress 3.4, TwonkyMedia 6.0.39 QPKG - Zenphoto1.4.2.1 [7802] - phpMyAdmin v3.3.10
Network: Netgear DG834G V4.01.40 - DGTeam Rev. 0849 -> Cisco RV220W 1.0.4.13, Cisco SLM2008, Dlink DSM-520, Xbox360
Posts: 5
Registered: ‎06-29-2006

Re: VPN does not work on WRT54G v6

The VPN Passthrough is enabled.
Posts: 518
Registered: ‎06-29-2006

Re: VPN does not work on WRT54G v6

[ Edited ]
if the client accessing the vpn server at all? are you able to get any log info from the vpn server?

what firewall features are enabled?

just checked on my site. v5 units seem to have a problem with vpn. it maybe a firmware problem, however an altenative is here:

get rid of the VxWorks firmware for good - Flashing third-party firmwares on to the WRT54G/GS v5, v6...

Message Edited by linksysinfo on 06-29-2006 10:16 PM

Regards Simon

NAS: TS-459 Pro - 3.6.1 Build0302T - 4 x 1TB Samsung HD103SJ : EXT4 - APC ES 700VA UPS
QPKG: WordPress 3.4, TwonkyMedia 6.0.39 QPKG - Zenphoto1.4.2.1 [7802] - phpMyAdmin v3.3.10
Network: Netgear DG834G V4.01.40 - DGTeam Rev. 0849 -> Cisco RV220W 1.0.4.13, Cisco SLM2008, Dlink DSM-520, Xbox360
Posts: 5
Registered: ‎06-29-2006

Re: VPN does not work on WRT54G v6

I changed the flash and it still doesn't work.
Posts: 3
Registered: ‎06-28-2006

Re: VPN does not work on WRT54G v6

I'm not using any specific VPN client, just the Windows XP VPN connection created through the New Network Connection Wizard.  This same connection worked fine on my former WRT54G v1 and also directly connected to cable modem, so problem resides in the router.
Posts: 9
Registered: ‎06-28-2006

Re: VPN does not work on WRT54G v6

Thru network connection you will have a pptp vpn connection. make sure that pptp passthru is enabled on the router. Try as well setting the computer to dmz.
"It is common sense to take a method and try it. If it fails, admit it frankly and try another.
But above all, try something."