Reply
royevans75
Posts: 4
Registered: ‎03-15-2010

WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Hello,

 

I have a new dell studio laptop with an internal "N" card as well as an xbox with an N adapter.  However, the "radio type" showin in my network list keeps saying "802.11g."  I have done the following:

 

Rebooted, reinstalled the router

Upgraded the firmware

reset to default and created a new ssid.

delereted and reinstalled the connections on both the laptop and the xbox.

 

When I change the setting in the setup page to "N only," both my computer and xbox lose their connections.

 

Spent an hour with linksys, they couldn't figure it out.  Any ideas???

oook
Posts: 3,809
Registered: ‎09-07-2006

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Change the Channel Width to 40MHz only,Wide Channel to 9 and Standard Channel to 11-2.462GHz and Click on save settings. Under the Advanced Wireless Settings..Disable Frame Burst,Change the N Transmission Rate to 7-65Mbps, Change the Beacon Interval to 75,Change the Fragmentation Threshold to 2304,Change the RTS Threshold to 2304 and Click on Save Settings...Power Cycle the router.

 

On the computer and X-Box,delete all the preferred network and try to connect again.

royevans75
Posts: 4
Registered: ‎03-15-2010

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Thanks - the tech on the phone had me do some of this...but not all of it...I will try all and report back tonight.

 

Out of curiosity, why should deleting the connection matter?  When my network card brings up the "list of available networks" I can connect to (even if I have no preferred connections set), it still shows my router as being 802.11G

 

Thanks again

royevans75
Posts: 4
Registered: ‎03-15-2010

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Unfortunately, not only did it not work but neither the computer or xbox could connect to the router after doing the changes.  I've had this same problem now with TWO different routers (same model).  Anyone have any further advice?  Really frustrated.

 

Thanks!

gserlenga
Posts: 1
Registered: ‎03-16-2010

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

I have the same model of router (WRT120N) with the latest available firmware and am having the same problem you are having with the network adapter software on the 2 wireless devices I have connected to this router only showing the wireless network I created as B and G, not N. I would not change the N Transmission Rate setting if you have B/G clients in your network because the help file under Wireless --> Advanced Wireless Settings in the router config page states: "Changing the N Transmission Rate other than Auto will disable B/G clients". I have not been able to try the other settings changes suggested by the previous poster, but I will report back here soon if I have any success with them. I would reset the changes you made back to their previous settings to at least make your laptop and Xbox able to connect to the router on 802.11b/g modes for now.
oook
Posts: 3,809
Registered: ‎09-07-2006

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Who is your ISP...?

 

As you upgraded the router's firmware,I would suggest you to reset the router for 30-35 seconds,Power Cycle the router and re-configure the router from scratch.

marshyrob
Posts: 3
Registered: ‎04-05-2010

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Hi

 

Did anyone figure this out yet?  I have the same issue.  My laptop does wirelss N standard and ive just purchased a wireless N Xbox adaptor.  They both connect fine but only at G standard. 

 

I dont have any bridges etc just the WRT120N router set as mixed mode.  If i change it to wireless N only, they both lose connection to the router, i have my desktop PC connected via ethernet so i change it back to mixed and they both reconnect again.

 

ISP should have nothing to do with the connection to and from the hardware, of course once out on the ISP backbone there maybe restrictions but just connecting my xbox adaptor to the router should not involve any ISP restrictions as ive configured the router myself. 

 

Is it to do with dual band?

 

Thanks

marshyrob
Posts: 3
Registered: ‎04-05-2010

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Ok figured this out i think.

 

This router is a single channel/Band router and i think it cannot cope with different devices on different security standards.

 

I changed all the devices in my network to WPA2 Personal AES as i had some set to TKIP and some to the TKIP or AES option.  Once changed to just AES, this changed the speed on my laptop to 65Mbps (from 54Mbps) and the Xbox changed to 802.11n.

 

Hope this helps.

 

 

 

 

royevans75
Posts: 4
Registered: ‎03-15-2010

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Worked!!!!!  Thanks!!  Two hours w/ cisco and they couldn't figure this out...

marshyrob
Posts: 3
Registered: ‎04-05-2010

Re: WRT 120N - Radio Type only shows as "802.11g." Cannot connect as "N"

Great, glad its worked with another setup, it sorta proves its the way this router works.  Enjoy!