Reply
Posts: 3
Registered: ‎07-19-2013

WRT120N: Can't log into Webinterface because of DNT header.

Hi all,

I'm using the latest Firefox (22.0) to log on to the web interface of my WRT120N router.

 

It only works, if the DNT (Do not track) HTTP-Header is absent.

Otherwise the router keeps returning a 401 (Authorization Required) response.

 

Shouldn't any webserver just ignore HTTP-Headers they do not understand?

 

Best regards

Posts: 855
Registered: ‎02-11-2013

Re: WRT120N: Can't log into Webinterface because of DNT header.

 

I believe so that this router model was released before 2010 when DNT has been implemented. It may be due to firmware version of the router. The latest firmware version for this router is 1.0.07 Build 2 which you can download from the Linksys website: http://support.linksys.com/en-us/support/routers/WRT120N.

Highlighted
Posts: 3
Registered: ‎07-19-2013

Re: WRT120N: Can't log into Webinterface because of DNT header.

That was the first thing I checked.

I updated the firmware -- no improvement.

 

Posts: 1,830
Registered: ‎04-22-2012

Re: WRT120N: Can't log into Webinterface because of DNT header.

I believe it has nothing to do with the router. DNT is a feature that you can enable or disable on your browser. There is an option though for this feature to be disabled. One thing to note is the purpose why it is enabled. Primarily, what DNT do is to tell the websites that you don't want your browsing behavior tracked. To disable this feature, you can find it under Privacy pane: on Windows, go to Tools > Options > Privacy > uncheck “Tell websites I do not want to be tracked”.

Posts: 3
Registered: ‎07-19-2013

Re: WRT120N: Can't log into Webinterface because of DNT header.

[ Edited ]

To be exact: There are three options in Firefox pertaining to the DNT header:

 

  1. "Tell sites that I do not want to be tracked." sends DNT: 1
  2. "Tell sites that I want to be tracked." sends DNT: 0
  3. "Do not tell sites anything about my tracking preferences." does not send a DNT header at all.

Only when the last option is selected, the router accepts my login. I checked that using Wireshark.

 

I might also mention, that I am a professional software developer and I know exactly, what the DNT header is supposed to say. Wether or not it really does bring something about is yet another question of couse Smiley Wink. Still I would like to have option 1 from above set. If only as a statement.

 

An that should not be any problem, right? May I quote from RFC2616 ?

Section 7.1 says: "... Unrecognized header fields SHOULD be ignored by the recipient ...".

 

The router's built-in webserver announces itself in the "Server:" header as being an "Apache".

Noting else. No version, no nothing. Really??? If this were really an Apache, it would just ignore any headers it doesen't know.

 

Best regards

W. Kleinschimt

Posts: 391
Registered: ‎12-31-2012

Re: WRT120N: Can't log into Webinterface because of DNT header.

This might be a firmware related issue. Let’s just hope that a new firmware will be released to fix this. You can also contact tech support for you to get more information regarding this concern.