Showing results for 
Search instead for 
Do you mean 
Reply
d3ll09
Posts: 2
Registered: ‎06-03-2009

WRT160N Problems

Having problems with my wireless router, dropping and keeping connection active. For some odd reason I keep dropping connection either wireless or wired. I have a long description that I am about to type and hopefully someone can help me with this issue. I have a total of 5 items going through this router. 2 of them are wireless and the other 3 are wired. The wireless items are a desktop computer that is using the Wireless USB adapter to get online. Sometimes it drops and most of the time it doesn’t have any problems. I have a laptop that sometimes the connection goes from strong all the way down to no connection at ALL. It starts at 54MBPS to down to the RED X over the wireless manager. Forgot to mention both of these machines are Windows XP. If I reboot the laptop, it comes up without any problems. Sometimes I tell Windows XP to manage the Wireless connection and tell it to disconnect and re-connect again, it goes. Now for the wired items, I have 2 gaming systems and another computer plugged directly up to the router. For some odd reason when I double click on the internet, on the computer that is hooked directly to the router, it says page couldn’t be found. I know that there is connection and there is nothing running in the task tray except for the Anti-Virus and Firewall. The browsers that I am using are Internet Explorer 8 and Mozilla Firefox 3.0.10.  Also checked on the back of the machine to see if I have link lights and everything is flashing. Finally, when I click the homepage or refresh button about 2 or 3 times, it goes through.

 

From what I see, I think that I am overloading this Router and it can’t handle it. Got some advice from someone and they said that I might have to look into sending "Keep Alive" packet setting on the router. Looked at it and didn’t do anything. If you have a solution on how to fix it, tell me. If someone thinks that I should get another router to handle all of this, please give me some links for them.

kevj
Posts: 689
Registered: ‎07-16-2006

Re: WRT160N Problems

There is a known issue with intermittent connectivity and the Build 11 firmware for the WRT160N V2. Build 11 is the current firmware on the Linksys site. Check to see if you have Build 11 if your router is a V2.
Downgrading to Build 8 is generally accepted to correct these issues, however Linksys have indicated to several people they do not have the build 8 firmware to give to end users.

This is ONLY for WRT160N V2 routers. This firware will not work on WRT160N V1.

You can find it at http://audipages.com/router/

Follow the dowload and firmware downgrade instructions on that page.
After the downgrade, factory reset the router and re-configure by hand (not via a config backup file)
-------------------------------------
Tomato 1.25vpn3.4 (SgtPepperKSU MOD) on a Buffalo WHR-HP-G54
D-Link DSM-320 (Wired)
Wii (Wireless) - PS3 (Wired), PSP (Wireless) - XBox360 (Wired)
SonyBDP-S360 (Wired)
Linksys NSLU2 Firmware Unslung 6.10 Beta unslung to a 2Gb thumb, w/1 Maxtor OneTouch III 200Gb
IOmega StorCenter ix2 1TB NAS
Linksys WVC54G w/FW V2.12EU
and assorted wired and wireless PCs and laptops
d3ll09
Posts: 2
Registered: ‎06-03-2009

Re: WRT160N Problems

After I downgraded it, the router itself crashed on me. It wouldn't connect, but I could go through my modem. Spoke with Linksys Technician and they would send me another one. Is there any other way to fix this problem without having to downgrade it.

kevj
Posts: 689
Registered: ‎07-16-2006

Re: WRT160N Problems

[ Edited ]

Are you certain you have the correct router version for the downgrade to work....my first post stipulates that it MUST be a WRT160N V2. The V1 or V3 routers will not accept the same firmware I don't beleive...

 

And if it is the correct version, did you perform a factory reset after the downgrade, and reconfigure the router?

Message Edited by kevj on 06-04-2009 06:40 PM
-------------------------------------
Tomato 1.25vpn3.4 (SgtPepperKSU MOD) on a Buffalo WHR-HP-G54
D-Link DSM-320 (Wired)
Wii (Wireless) - PS3 (Wired), PSP (Wireless) - XBox360 (Wired)
SonyBDP-S360 (Wired)
Linksys NSLU2 Firmware Unslung 6.10 Beta unslung to a 2Gb thumb, w/1 Maxtor OneTouch III 200Gb
IOmega StorCenter ix2 1TB NAS
Linksys WVC54G w/FW V2.12EU
and assorted wired and wireless PCs and laptops
Carrot
Posts: 3,271
Registered: ‎09-07-2006

Re: WRT160N Problems

Normally a firmware downgrade should not crash the router, maybe you have WRT160N v1 or v3 and you tried downgrading the firmware and maybe that's the reason it crashed...

 

You should try to hard reset your router for 1 minute and see what happens...

 

Press and hold the reset button for 1 minute...Release the reset button...Unplug the power cable from your router, wait for 1 minute and re-connect the power cable...Now re-configure your router...

byrdhome
Posts: 1
Registered: ‎09-24-2009

Re: WRT160N Problems

I've have Wrt160N V2 I did see that there is up graded firmware.

Will this fix the dropage?

This downloads as a .bin file. Is this correct?

Firmware
  • 07/21/2009

    Ver.2.0.03

  • Download 3.25 MB

    (Firmware)

     

krull1755
Posts: 2
Registered: ‎10-06-2009

Re: WRT160N Problems

Thank you  kevj...i have been trying to resolve this problem for months, the call enter wasn't much help.  The only thing that wasn't working was my desktop, my network worked.  The instructions you posted worked like a charm. 

Thanks again. 

ksmalley
Posts: 1
Registered: ‎10-16-2009

Re: WRT160N Problems

I sincerely wish I had read these post before purchasing the WRT160N V2 router two weeks ago!  I have had nothing but problems with loosing connectivity and I agree the support center was not much help at all.  Perhaps part of their customer service training should include being aware of existing issues with the products instead of falsely charging for remote access when they know there is a problem with the equipment.  I have been a Linksys user for years and decided to upgrade my router.....big mistake!  I am returning this router tomorrow as suggested by support rep #12225-Al.

1i
1i
Posts: 2
Registered: ‎10-24-2009

Re: WRT160N Problems

I have a WRT160N, I assume version 1 as it has no version number listed. It has firmware v1.02.4-CA Dec 19, 2007, which is helpfully dated earlier but numbered later than the 1.02.02 US firmware. The router frequently (at least daily) drops all connections, wireless and wired. I  unpower the router for 20 seconds, reconnect the power, and it works again. For a while. Of course, all stateless connections are terminated, so it's brutal on http downloads. Will changing to the 1.02.02 US firmware fix this?
fuelnfire1
Posts: 1
Registered: ‎10-30-2009

Re: WRT160N Problems

I have a wrt160n v3

the problem we are having is after about 2 weeks it shows signal but we cannot connect to internet, Im not big into computers but we loose the internet on the wireless computers and the wired computers. if I disconnect the wired from the router and direct to dsl we have internet only on wired computers . it shows signal but keep getting error messages, tried the one minute reset with no cure. we had to exchange it last time it did this , worked for about 2 weeks and crashed again.