Showing results for 
Search instead for 
Do you mean 
Reply
BigDaddyPJS
Posts: 2
Registered: ‎05-11-2008

WRT160N-Slow access via wireless connection.

I have a WRT160N with one desktop connected via a lans cable, another desktop connected wireless via WUSB300N and a Laptop connected wireless via WPC600N.
 
First of all, my internet provider is comcast and my connection is cable.  My desktop connected directly to the WRT160n via lans cable doen't have any problem with speed.  My wireless connection thru my other desktop and laptop is marginal at best and gets worst when downloading large files.
 
My wireless setting were:
 
Network mode: Mixed
Radio Band: Auto
Standard Channel: Auto
SSID Broadcast: Enable
 
I have changed the setting many different times to N Only, with diffent channels, standard-20MHz, Wide-40MH, reset to factory and started over again with no increased performance.
 
I have changed my security setting to WEP and WPA2.  This also had no effect on the wireless performance.
 
To get any kind of speed out of my wirless connection.  I had to set my Basic Wireless setting to the following:
 
Network Mode:  G Only
Standard Channel: 10-2.457GHZ
 
Can anyone tell me why I have to go to G Only on a N router with two computers with N network cards installed to get any kind of speed or performance?
 
I do have the most recent firmware, and drivers for all my network adapters.  I am running Vista Ultimate on booth desktops and Vista Home Premium on Laptop.
 
 
quack
Posts: 2,544
Registered: ‎09-07-2006

Re: WRT160N-Slow access via wireless connection.

Well you need to open the setup page of router using 192.168.1.1 & as you are having the wireless N-series router make sure the mode you select is mixed doesnt' really matter so just the wireless settings should be Radio Band frequency should be 20 MHZ, standard channel change to 11 & the advanced wireless settings should be Beacon Interval 2306,  Rts thres = 2307 & disable the Security easy setup option.Also, uncheck the Block Anonymous Internet Requests & reduce the MTU size to  1400 will definately work!!
BigDaddyPJS
Posts: 2
Registered: ‎05-11-2008

Re: WRT160N-Slow access via wireless connection.

Just tried the suggested settings.  Worked like a charm!  Thanks!
harrytcs
Posts: 1
Registered: ‎01-06-2010

Re: WRT160N-Slow access via wireless connection.

Hi

 

I tried all the settings yesterday night and it really worked like a charm.  I shutdown my laptop yesterday night and restarted it today morning and again the wireless connectivity is very slow.  Please help

TakeItAndGo
Posts: 1
Registered: ‎08-24-2012

Re: WRT160N-Slow access via wireless connection.

Hi,

 

I have the same problem with my Linksys WRT 160N V3 router. Firmware is upgraded to 3.0.03 version. I am using Windows 7/8 and I have several devices connecting to the router: 2 laptops at N, and couple of cell phones.

 

I tried resetting the router - the speeds are good for few hours like 19 Mbps (wireless when wired connection to router is 35Mbps) but it drops to 2-5Mbps. Also I noticed, that when the speeds were good, if I take my laptop far away from the router (around 20 -30 ft away), then the speeds on my wireless connection dropped from 19Mbps to 5Mbps. So certainly a problem with the range on my router. But still dont get why all connections slows down after few hrs.

 

I tried setting the Channel Width to 20 MHz Only and Channel No. to 11. Also tried Diabling WMM support under Applications & Gaming -> QOS support.

ScarletJamie
Posts: 1,534
Registered: ‎04-22-2012

Re: WRT160N-Slow access via wireless connection.


TakeItAndGo wrote:

Hi,

 

I have the same problem with my Linksys WRT 160N V3 router. Firmware is upgraded to 3.0.03 version. I am using Windows 7/8 and I have several devices connecting to the router: 2 laptops at N, and couple of cell phones.

 

I tried resetting the router - the speeds are good for few hours like 19 Mbps (wireless when wired connection to router is 35Mbps) but it drops to 2-5Mbps. Also I noticed, that when the speeds were good, if I take my laptop far away from the router (around 20 -30 ft away), then the speeds on my wireless connection dropped from 19Mbps to 5Mbps. So certainly a problem with the range on my router. But still dont get why all connections slows down after few hrs.

 

I tried setting the Channel Width to 20 MHz Only and Channel No. to 11. Also tried Diabling WMM support under Applications & Gaming -> QOS support.


Try customizing advanced wireless settings. Set beacon interval to 50, fragmentation threshold to 2306 and RTS threshold to 2307.

 
Expert
jlbjlb
Posts: 2,736
Registered: ‎07-07-2012

Re: WRT160N-Slow access via wireless connection.

Use inSSIDer to help you find the best channel.

 

http://www.metageek.net/products/inssider/

icufoundme
Posts: 1
Registered: ‎07-21-2013

Re: WRT160N-Slow access via wireless connection.

I was having this issue after changing from ATT DSL top Comcast Xfinity. My connection was fine when connected directly by ethernet, then terrible with wireless. So bad I could not watch netflix movies. I tried a bunch of different configurations from googling, and it was just  one setting that fixed it - cloning my PC's MAC address per the linksys FAQ:

http://kb.linksys.com/Linksys/ukp.aspx?pid=80&app=vw&vw=1&login=1&json=1&docid=0ff4c94586a345d082828...

Now my speeds are the same as wierd when wireless, yay!