Reply
Johnny_G
Posts: 3
Registered: ‎12-01-2010

WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

There seems to be a number of posts pertaining to this subject. The recommendations are all over the place in terms of tweaks to make to a number of the router settings. I found that one change, recommended in this forum, has made all the difference for me. First, I am using Firmware Version: v1.0.10 Build 2, which I installed last week. Go to the router settings then Applications and Gaming then QoS. Chances are, you will find that the WMM setting is disabled. Change it to ENABLED. This one change got my router up to 216 Mbps immediately and in some areas of the house up to 270 Mbps. Prior to this, I was never able to achieve a speed > 54 Mbps.

 

Some of the other changes to settings, recommended in this forum, that DID NOT EFFECT THE PROBLEM are:

 

1- Changing the Radio Band to STANDARD and also changing the Standard Channel to 11. Leave your Network Mode to Mixed and everything else on AUTO.

2- Beacon Interval - various values recommended made no difference

3- Fragmentation Threshold - various values recommended made no difference

4- RTS Threshold - various values recommended made no difference

5- Frameburst - changed to DISABLED, made no difference

6- Under Wireless Security - changed from TKIP or AES to just AES, made no difference.

 

For me, leaving these settings at their default works. My only change was changing WMM to ENABLED.

 

Hope this helps!

 

 

Expert
sabretooth
Posts: 5,274
Registered: ‎11-11-2008

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

WMM enabled is the default setting.  So it looks like yours was changed maybe?

Johnny_G
Posts: 3
Registered: ‎12-01-2010

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

I just bought it last week and did the upgrade on the firmware as per my original post. I then configured basic Wireless and Security settings. Never even looked at QoS. I also read at least one post in this forum that said to enable this, so I'm not quite sure if this is always ON by default. Thanks!

nybackus
Posts: 8
Registered: ‎01-08-2011

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

I just went to QoS for the first time.  WMM support is listed as enabled. "No acknowledgement" is listed as disabled. And "Internet Access Priority" is listed as disabled.  Should I change any of these to achieve speeds faster than 54Mbps?

Disgruntled
Posts: 19
Registered: ‎05-11-2010

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

If You are using WPA encryption - it will default you to (54 Mbps).  To secure a higher speed you must use WPA2 / AES encryption but this is very limited as it is device driven than software.  If you have connected any Wireless G devices on your network, it will default down to G status - which is 54 Mbps of speed.    I have a laptop with Wireless N card supporting WPA2 /AES encryption and I am able to reach 132 Mbps of speed and on a better day one time reached 137 Mbps. 

 

Remember:  This is your capabilities of transferring data within your LAN environment.  Your ISP depending on the package you subscribe to is on average  5.3 - 7 MPBS  where you have 1- 2 MPBS of download speed. 

 

The test environements are CLEAN.  They use Wirless N cards supporting WPA2 /  AES with all supporting devices having the same specifications so it is very easy to achieve the 150 + mpbs router speed but the average consumer has a mix and match of many therefore anyone contemplating getting rid of their old  WRT54G (54 mpbs) work horse for better results - KEEP IT.  This may be the last time to see  quality built and performed driven (WRT54G)  because I am not achieving anything near expectations with my WRT310N.   One certainty is that I seldom experienced any outages with my WRT54G but with the WRT310N - it requires a monthly reboot for whatever cause (loses speed, connectivity issues - up then down) - very unreliable and think hard about using the FREE Network Magic.  There is an old saying "Nothing is FREE"...  read the blogs and comments from many ...

 

 

 

 

nybackus
Posts: 8
Registered: ‎01-08-2011

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

I have wireless g computers.  Is there something I can plug into a USB port (or elsewhere) to upgrade it to wireless N?

Expert
sabretooth
Posts: 5,274
Registered: ‎11-11-2008

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

Yes it's called a wirleless USB N adapter.

nybackus
Posts: 8
Registered: ‎01-08-2011

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

So... if I follow you correctly, having a wireless-N adapter will get me speeds faster than 54 Mbps as long as no other wireless-G computer is connected to the Internet at the same time?  If my computer is the only one on and I'm using the wireless adapter (Linksys AE1000) I'll get faster speeds until my wife powers up her wireless-G computer at which point it'll drop back down to 54 Mbps?  Unless, that is, she also has a wireless-N adapter?

Expert
sabretooth
Posts: 5,274
Registered: ‎11-11-2008

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

Basically yes.  You will only actually slow down the N speed when the G adapter is transferring data.  It will just slow it down a bit.

 

Go here for more info...

 

http://www.smallnetbuilder.com/wireless/wireless-basics/30664-5-ways-to-fix-slow-80211n-speed

Disgruntled
Posts: 19
Registered: ‎05-11-2010

Re: WRT310N Cannot Achieve Speeds Faster than 54 Mbps {FIX}

You can access your router using 192.168.1.1

Under the Wireless button select Basic Wireless Settings

Change your Configuration View to  MANUAL

Change your Network Mode to   MIXED

 

Under Wireless Security

Change the Security Mode to   WPA2 Personal

Change encryption to  TKIP or AES    on your laptop netwrok selection  choose  AES

 

On the Wireless G  device   Choose Security  to WPA Personal

Change encryption to  TKIP (AES)- some wireless G may not support AES

 

 

Thsi will provide a mixed network providing the  N with  130+  mpbs speed and  the wireless G to the 54 mpbs