Showing results for 
Search instead for 
Do you mean 
Reply
rhythmofself
Posts: 2
Registered: ‎09-28-2009

WRT310Nv2 Sporadically pointing domains to different websites...

I've been having a weird issue lately with my WRT310Nv2. Sometimes when we, and by we, I mean two different computers (one Mac, one XP PC), try to go to a website, it will point us to an entire diffrently website. For example, earlier today I attempted to go to Twitter and twitter.com appeared as some random Blogger website. I've had issues where Amazon.com kepting point to UPS.com, or Facebook.com pointing to MySpace.com, etc.

 

I haven't been able to pinpoint a regular pattern, except the fact that it is most likely the wireless network, since the Windows PC (Server 2003) plugged directly into the router has never had this issue.

 

Has anyone else experienced this issue?

Wizzard
Posts: 3,025
Registered: ‎09-07-2006

Re: WRT310Nv2 Sporadically pointing domains to different websites...

Are you getting the same problem when you connect the computer directly to the modem..?
rhythmofself
Posts: 2
Registered: ‎09-28-2009

Re: WRT310Nv2 Sporadically pointing domains to different websites...

Wizzard,

 

There is a desktop PC (Windows Server 2003)  that is plugged directly into the router that has not experienced this issue.

Wizzard
Posts: 3,025
Registered: ‎09-07-2006

Re: WRT310Nv2 Sporadically pointing domains to different websites...

Your router seems to be working fine here as you are getting the internet connection and router doesnot have the ability to redirect the website.However you can check on the computer if there is any malware installed in it.
Client_No.9
Posts: 6
Registered: ‎12-07-2009

Re: WRT310Nv2 Sporadically pointing domains to different websites...

Rhythm,

 

So glad to see that someone else is having this problem. We started experiencing it several months ago. It looks like a DNS resolution error but it's weird as hell. The two websites I have the most trouble with are www.foxnews.com redirecting to www.washingtonpost.com and www.facebook.com redirecting to a users page on www.myspace.com. Sometimes facebook also redirects www.mysite.com or something like that.

 

I've been working on this a bit and I do not believe that the router is involved, nor is it a problem with malware. My PC has a fresh load of Windows 7 on it just installed a month ago. I am experiencing it now just as I did when I have Vista on it earlier this year. My wife also has the problem on her Apple Macbook, so it isn't malware. I have also reloaded the firmware and default settings on the router so i'm pretty sure that's not it.

 

Now, to really bake your noodle...... I had this problem on AT&T DSL earlier this year, I just switched to Comcast Cable Modem to get more bandwidth and I still have the problem.

 

So, I'm sure it's not my computer, or my wife's Mac. The router just passes DNS requests, it doesn't act on them so i'm pretty sure it's not the router.

 

I can fix the problem by closing my web browser, then opening up a command prompt on windows and issuing the command c:\ipconfig /flushdns. Then reopen the browser and try again, 99% of the time that works. It flushes the DNS cache and forces the computer to issue a new DNS resolution request to the DNS server. On the Mac, open a terminal and type dscacheutil -flushcache.

 

I believe that the problem lies out in "the cloud", most likely with the website server itself or a caching service such as Akamai (i.e. akadns.net). It is also possible that someone is poisoning DNS routes with a rouge server. The fact that it is happening on both AT&T and Comcast with two different DNS servers is what I find so weird about this. I am probably going to contact Comcast to talk through it with them too but I have very low expectations on their being able to understand the problem much less fix it. We'll see.

 

C.

ses4j
Posts: 3
Registered: ‎01-31-2010

Re: WRT310Nv2 Sporadically pointing domains to different websites...

I think I have exactly the same problem you guys are describing.  Any computer or phone connected to my home LAN via either wired or WiFi, occasionally gets DNS records confused.  For example, my iPhone when on WiFi will sometimes report that the google.com SSL certificate is wrong, because it tried to go to gmail and instead got some other site, often a wikimedia page.

 

My LAN is configured to hit the WRT310N for DNS first:

   DNS Servers . . . . . . . . . . . : 192.168.1.2
                                       71.252.0.14
                                       71.242.0.14

 

I disagree that it's "in the cloud"... When I bring a laptop or the phone somewhere else to connect, like to work all day, I never see it happen.  Only on my home network, and only since I got the WRT310Nv2.  So I know it's not any one computer, and I know it's symptomatic of my network alone. 

 

The only thing besides faulty software in the 310N that it could be is a misconfiguration of the 310N with the Verizon DSL modem.  I configured the modem to be a passthrough and to use the 310N for everything networky, but that stuff is tricky and maybe I messed it up somehow?

 

Any ideas on how to isolate the problem further?

 

petey2001
Posts: 2
Registered: ‎02-04-2010

Re: WRT310Nv2 Sporadically pointing domains to different websites...

I have the same issues as you guys. Looks like we aren't the only Linksys users with these issues.  Facebook randomly goes to USAToday for me and the OttawaCitizen and Globe and Mail websites redirect to Google. Twitter frequently gets an "Invalid URL /" error (as do some other sites) or also sometimes goes to Blogger. 

 

http://forums.linksysbycisco.com/linksys/board/message?board.id=Wireless_Routers&thread.id=146716&vi... 

http://www.brownbatterystudios.com/sixthings/2009/11/18/who-the-hell-is-samuel-garcia-the-facebook-r... 

 

this is supposed to be a potential solution, I haven't tried it yet

http://forums.linksysbycisco.com/linksys/board/message?board.id=Wireless_Routers&view=by_date_ascend... 

ses4j
Posts: 3
Registered: ‎01-31-2010

Re: WRT310Nv2 Sporadically pointing domains to different websites...

Thanks for the links, I don't feel so alone now.  Their "solution" is a workaround that won't work for me, as I also need the local DNS to map between the computers in my local network.  The solution I need is for Linksys to fix their buggy DNS cache.

petey2001
Posts: 2
Registered: ‎02-04-2010

Re: WRT310Nv2 Sporadically pointing domains to different websites...

The workaround worked great for me... *knock on wood* Although I haven't checked if there are issues for any other computers on the network.  Agreed this is a pretty significant bug. 
jkwakopo
Posts: 3
Registered: ‎02-12-2010

Re: WRT310Nv2 Sporadically pointing domains to different websites...

I have WRT310n v2 and i had this DNS problem for long time..... I followed your instructions exactly and took out my routers ip from DNS and used the other 2.. It works great and the problem instantly gone!!!.. Thanks  wbundrick!! 

 

I'll let you know if this gay DNS **bleep** happens again.. '

 

 

Jae

Kudos!
02-12-2010 06:42 PM