Reply
danielmical
Posts: 6
Registered: ‎06-25-2010

WRT320N does not connect at 300 Mbps

I have a WRT320N router which is advertised to connect at 300 Mbps on 802.11N. However every time I connect my laptop it only connects at 150 Mbps.

 

The Channel width on the router is set to "Auto 20MHz or 40MHz", Auto Channel, and use the WPA2 Personal encryption.

 

If the channel width is set to 20MHz, the connection peeks at 72 Mbps.

 

It looks like the connection is only using one stream, or am I missing something ?

 

If this may help:

The laptop uses the Intel 6200 Advanced-N wireless card.

 

Klatch
Posts: 2,829
Registered: ‎09-07-2006

Re: WRT320N does not connect at 300 Mbps

Open the router setup page and Under the Wireless tab,Change the Radio Band to Wide 40 MHz only,Wide Channel to 9 and Standard Channel to 11-2.462Ghz.Under the Advance Wireless Settings,Change the N Transmission Rate to 15-130Mbps and click on save settings.Power cycle the router and check.

danielmical
Posts: 6
Registered: ‎06-25-2010

Re: WRT320N does not connect at 300 Mbps

The option to set the channel width to "40 MHz only" is not available on the router, and channel selection can only be set to "Auto" when the channel width is set to "Auto (20 MHz or 40 MHz)".

 

 

Under the Advance Wireless Settings, after changing the N transmission rate to "15- 130 Mbps", no device would successfully connect.

Klatch
Posts: 2,829
Registered: ‎09-07-2006

Re: WRT320N does not connect at 300 Mbps

Try to keep the Channel Width to 20MHz only and Channel to 11..Now,check.If that does not resolve the issue then,try to reflash the router's firmware and re-configure the router from scratch.

danielmical
Posts: 6
Registered: ‎06-25-2010

Re: WRT320N does not connect at 300 Mbps

Did all those things but still no luck. I am noticing though that when I connect, the connection speed goes to 180 Mbps but then immediately goes back to 150 Mbps. Also that the signal strength is reaching at most 4 bars of 5, even when the laptop is next to the router. Could this be an issue ?

Klatch
Posts: 2,829
Registered: ‎09-07-2006

Re: WRT320N does not connect at 300 Mbps

You can try by upgrading/reflashing the router's firmware.After upgrading the firmware reset the router and re-configure the router from scratch. 

danielmical
Posts: 6
Registered: ‎06-25-2010

Re: WRT320N does not connect at 300 Mbps

Same results. however since i changed the band to work on 5GHz, The laptop initially connects at 300 Mbps but will immediately drop back to 150 Mbps after 1 or 2 seconds.

dudztgp
Posts: 1,496
Registered: ‎06-27-2010

Re: WRT320N does not connect at 300 Mbps

- In Network Mode, select Wireless N only. Set the SSID to something unique. This should add selection to Channel Width.
- In Channel Width, select 40Mhz only.
- In Wide Channel, select Wide-40Mhz Channel.

Some selection appears only when the proper option is selected.

HTH
danielmical
Posts: 6
Registered: ‎06-25-2010

Re: WRT320N does not connect at 300 Mbps

I don't have "40 MHz only" but "Auto 20 MHz or 40 MHz" at most, nor "WIde channel Wide-40 MHz" anywhere in the router's settings.

 

Wireless settings are set to Wireless-N only and I do have a unique SSID.

 

But Thanks anyway, at this point I can't see any further solutions and anything is appreciated.

D00MBR0TH3R
Posts: 2
Registered: ‎06-13-2010

Re: WRT320N does not connect at 300 Mbps

If you want 40 hz.. I suggest switching the firmware to DD-WRT. Their firmware has the 40mhz feature. Google it.