Reply
Posts: 2
Registered: ‎12-04-2017

WRT32X Slow phone downloads.

I purchased the above wireless router yesterday.l Setup went well, and my wired desktop and wireless Firetv are working fine.
The issue I have is with my iPhone and my wife's android smartphone. When I use speed test on each of these phones I get great download and upload speeds of at least 50mbps down and 12mbps up. Surfing the web and streaming youtube also seems fine.
The problem is downloading things such as apps and youtube videos... They are painfully slow to download. Apps which used to take seconds to download now take many minutes. This is happening with both my iPhone and my wife's android
phone. I have even tried giving both these devices a high priority within the router software but to no avail.
Is there a fix for this because if there isn't I'll be forced to return my router which I really don't want to do?
Posts: 49
Registered: ‎01-05-2010

Re: WRT32X Slow phone downloads.

What firmware is on your WRT32X?  Linksys just released an updated firmware which is causing a lot of problems.  See the post here: https://community.linksys.com/t5/Wireless-Routers/WRT32X-Dropping-Wifi/td-p/1238020

 

I'm still on v 1.0.170828.208 (Auto Update set to Never) and am not experiencing anything like you are describing.

Posts: 77
Registered: ‎06-07-2016

Re: WRT32X Slow phone downloads.

Might try changing Mixed modes to single mode N on 2.4Ghz and set WPA2 Personal and AES only and manual channell 11. Same thing for 5Ghz accept manual channel 48 or someting else. 

Posts: 3
Registered: ‎12-04-2017

Re: WRT32X Slow phone downloads.

I downgraded back to .208 and the slow WiFi was fixed
Posts: 77
Registered: ‎06-07-2016

Re: WRT32X Slow phone downloads.

Be sure you hold on to that file. Linksys doesn't post downloads for the 32x currently. Smiley Frustrated

Posts: 3
Registered: ‎12-04-2017

Re: WRT32X Slow phone downloads.

I have the link to the download, I'll post below. But this is what I had to do. Now Im back on .208 and have the firmware image downloaded, and no auto updates.

 

1. Goto Router Admin and manually upload the .208 firmware image, and install.

2. Upon install/reboot internet wasnt working which i expected. I had to perform a 30-30-30 reset on the router

3. When 30-30-30 reset is done and you can access the default router page at 192.168.1.1 before completing setup i shut off my cable modem to prevent the setup from auto-updating again..

4. Once cable modem is shut-off I hit the skip setup link on the default page.

5. Goto Router admin once at the dashboard, and select auto updates to NEVER, then save.

6. Goto dashboard and hit restart router.

7. Configure your wifi, lan, and other settings the way you want them

 

 

Firmware link to official linksys wrt32x version .208

http://downloads.linksys.com/downloads/firmware/FW_WRT32X_1.0.170828.208.img

 

 

PS. Hope this helps some people having issues with the .271, and waiting endlessly for Linksys to publish a fixed firmware.

 

-Project Orac1e

Posts: 5
Registered: ‎11-28-2017

Re: WRT32X Slow phone downloads.

Thank you so much.
Posts: 1
Registered: ‎12-06-2017

Re: WRT32X Slow phone downloads.

Hey All,

So I can confirm I was having this EXACT same issue. 

My wife and my iPhones had EXTREMELY slow and erratic download speeds, sometimes going from 30Mbps to 0.75Mbps. I pay for 250+Mbps! This was happening on our Android tablets as well. The strange thing was, it was not happening on our laptops, desktops, or Roku streaming boxes. 

I called Linksys and they tried everything, thinking it was an issue with one of the radio bands, but didnt work, and they wanted me to RMA it. 

So instead of doing that, I stumbled across this thread (THANK GOODNESS!) and tried the steps. I downloaded the firmware, 

  • Version 1.0.170828.208 from the link provided. 

I uploaded it to my router, and after the reboot, DHCP would not function at all, so I did a reset by holding the red reset button in. After this, it started up, but it began to automatically download the latest firmware again. Once it loaded, I connected with my phones, and still slow speed! 

So what I did was upload the older firmware, .208, once it restarted, DHCP wouldnt function again, so i did the reset. Before that though, I unplugged the WAN connection to the modem. After the reset, it couldnt connect to attempt to do a firmware update. After I got everything set up, I immediately changed it to NEVER check for an update. After that, I connected the WAN port back to my modem, and ran a speed test and all good. 

I ran a speed test, and now consistently I am getting 250+Mbps on all my devices, with no deviation. 

The only downfall to this whole thing, is that the Killer Enabled Setting is now not detecting my Killer Devices like it did before on the last firmware update. Before this, I normally had to power off my router by unplugging the power (not flipping teh little power switch on the back) and then it would detect. Not the case now.

I will update this if anything changed, but for now, I am ok with it. I can manually prioritize my killer-enabled devices. 

I will be letting the Linksys engineer who gets back to me tomorrow about this incident. 

Thanks!

-Rob

Posts: 2
Registered: ‎12-04-2017

Re: WRT32X Slow phone downloads.

Thanks for posting the older firmware fix.
I decided to send back this router and ended up with a Linksys ea7500.
I'm hoping a new firmware comes our for the wrt32x and I can reconsider it.
Posts: 77
Registered: ‎06-07-2016

Re: WRT32X Slow phone downloads.

You might try a factory reset, download the older version of FW. Do this with out the router being online with the ISP service. Factory reset the router again and set up from scratch and go in and disable the auto update. Then put the router online with the ISP service. 


robdarftw wrote:

Hey All,

So I can confirm I was having this EXACT same issue. 

My wife and my iPhones had EXTREMELY slow and erratic download speeds, sometimes going from 30Mbps to 0.75Mbps. I pay for 250+Mbps! This was happening on our Android tablets as well. The strange thing was, it was not happening on our laptops, desktops, or Roku streaming boxes. 

I called Linksys and they tried everything, thinking it was an issue with one of the radio bands, but didnt work, and they wanted me to RMA it. 

So instead of doing that, I stumbled across this thread (THANK GOODNESS!) and tried the steps. I downloaded the firmware, 

  • Version 1.0.170828.208 from the link provided. 

I uploaded it to my router, and after the reboot, DHCP would not function at all, so I did a reset by holding the red reset button in. After this, it started up, but it began to automatically download the latest firmware again. Once it loaded, I connected with my phones, and still slow speed! 

So what I did was upload the older firmware, .208, once it restarted, DHCP wouldnt function again, so i did the reset. Before that though, I unplugged the WAN connection to the modem. After the reset, it couldnt connect to attempt to do a firmware update. After I got everything set up, I immediately changed it to NEVER check for an update. After that, I connected the WAN port back to my modem, and ran a speed test and all good. 

I ran a speed test, and now consistently I am getting 250+Mbps on all my devices, with no deviation. 

The only downfall to this whole thing, is that the Killer Enabled Setting is now not detecting my Killer Devices like it did before on the last firmware update. Before this, I normally had to power off my router by unplugging the power (not flipping teh little power switch on the back) and then it would detect. Not the case now.

I will update this if anything changed, but for now, I am ok with it. I can manually prioritize my killer-enabled devices. 

I will be letting the Linksys engineer who gets back to me tomorrow about this incident. 

Thanks!

-Rob