Showing results for 
Search instead for 
Do you mean 
Reply
aeremita
Posts: 4
Registered: ‎02-04-2009
Accepted Solution

WRT54G V8 wired connection recently got very slow. HELP!

Hello, I have a WRT54G V8.0 wireless router. I bought it about 3 months ago, and it was working just fine. But on the last coupe of days, the connection speed became really slow.

The setup is as follow: 2 PCs connected directly by wire, and one connected through the wireless connection. All three of them use Windows XP.

I connected the modem directly to one of the PCs and speed improves a lot. Then I connected only that PC through the router (disabling the wireless connection) and speed goes down again, so I'm pretty sure it's the router.

I did some testing using the speedtest.net website and, with the modem directly connected to the PC, I get 1024 Kbps (my connection) all around the world, but with the router on, connection speed drops to 200-400 Kbps depending on how far the test server is located. I already had the latest firmware upgrade (8.0.0.5) and I've reseted the router back to factory settings, but speed still really slow.

I'm not using any firewall on neither of the PCs, except for Windows XP default firewall.

Any ideas?

Thanks in advance

Wizzard
Posts: 3,025
Registered: ‎09-07-2006

Re: WRT54G V8 wired connection recently got very slow. HELP!

If your wired connection is slow you should try to change the MTU Size on your router set-up...

 

Open an Internet Explorer browser page.In the address bar type - 192.168.1.1
Leave the username blank & in password use admin in lower case...

 

On the set-up page, for MTU select manual and change the MTU size to 1350 and click Save Settings and see if it improves the connection/speed, if not try changing the MTU size to 1300 and see if that makes any difference...

aeremita
Posts: 4
Registered: ‎02-04-2009

Re: WRT54G V8 wired connection recently got very slow. HELP!

It's not that. I've tried Auto, and I've tried Manual with a bunch of values from 576 to 1500 and connection speed doesn't improve.

caithford
Posts: 7
Registered: ‎03-19-2009

Re: WRT54G V8 wired connection recently got very slow. HELP!

[ Edited ]

Check your physical connections and ethernet cable.  A pinched ethernet cable can cause slowdowns and other problems.  Try swapping known good cables in too.

 

The other likely canidate would be large amounts of bandwidth consumption on the wireless side.  Torrent clients, games and downloading can cause such slowdowns.

 

It is also possible that in the QoS section of the configuration, someone set you to low priority in order to take up more bandwidth, or a higher switching/routing priority over your packets.

 

I've found that these units are susceptible to overheating.  Try to place it in an open air environment, and even try to actively cool it with a fan, and see if that helps you at all.

 

I hope that gives you a place to start.

Message Edited by caithford on 03-19-2009 05:08 PM
Wizzard
Posts: 3,025
Registered: ‎09-07-2006

Re: WRT54G V8 wired connection recently got very slow. HELP!

As you have tried all the possible settings on your router to improve the speed. I think it could be the problem with the router's firmware. May be your can do is, Re-Flash the firmware on your router, once the firmware is upgraded Press and hold the reset button for 1 minute...Release the reset button...Unplug the power cable from your router, wait for 1 minute and re-connect the power cable...Now re-configure your router...
aeremita
Posts: 4
Registered: ‎02-04-2009

Re: WRT54G V8 wired connection recently got very slow. HELP!

[ Edited ]

 It's not the physical connection because I've tried both cables on the Modem Only configuration and both work well.

Wireless connection is disabled so that is not a problem, and I'm not sure what QoS is but it says it's disabled (under Gaming & Applications).

I've notice there were a bunch of papers laying on the router for a couple of days, so that may have caused overheating, but it never smelled like burned electronics or something like that, I'll try cooling it, and also re-flashing the firmware as suggested by Wizzard, and I'll post back.

Thanks for all the advice.

Message Edited by aeremita on 03-20-2009 05:47 PM
caithford
Posts: 7
Registered: ‎03-19-2009

Re: WRT54G V8 wired connection recently got very slow. HELP!

I wish you luck.  In my experience, the papers could certainly do it.  You wouldn't necessarily smell burning electronics, since if you did smell the magic smoke leaving, it would likely not be working at all.

 

I had a router, not covered, in a slightly confined space and it was overheating.  When I removed it from the top of my wife's pc to the top of her desk, it sped right back up.

 

Re-flashing the firmware is also a good option.  I hope that you get it working again.

Wizzard
Posts: 3,025
Registered: ‎09-07-2006

Re: WRT54G V8 wired connection recently got very slow. HELP!

Sure you can try that, And i think this will solve the issue. It may be because you router must be getting overheated, so that could be one of the reason, why you were receving low speed from the router. As you have already noticed that, So you can place you router in such a place, that it wont get overheated next time. And you can Re-Flash the firmware on your router. I think that might solve the problem.
aeremita
Posts: 4
Registered: ‎02-04-2009

Re: WRT54G V8 wired connection recently got very slow. HELP!

Well... it's working again! Thanks a lot to everyone who aported ideas.

 

What I did was:

-Let it cool off for a couple of days :smileytongue:

-Move it on a more ventilated place

-Re flash the firmware

 

 I'm not sure if it was overheating or the firmware that caused the problem

 

Once again, thanx a million.

sunday67
Posts: 2
Registered: ‎06-07-2009

Re: WRT54G V8 wired connection recently got very slow. HELP!

how do you FLASH firmware? i have had trouble trying to upgrade the firmware on my router (The same make and model).

once downloaded, t says that the file type (.bin) can not be recognized, and that's where i get stuck.

 

thanks!