Reply
Posts: 4
Registered: ‎10-09-2009
Accepted Solution

WRT54G Wireless Not Working

Hello all, I am at my wits' end at what to do about this, and would appreciate the community's help.

 

I have DSL service, two computers with Windows XP, and a WRT54G v8 router, firmware v8.00.7 build 01.  One of the computers has a wired connection through the router while the other is connected wirelessly.  My problem is that the router's wireless functions do not work, despite having all relevant lights on (Power, WLAN, 1, Internet).  My ISP is not to blame as I can connect to the internet just fine through a wired connection to the router. 

 

I have used the troubleshooting functions in the EasyLink Advisor.  It claims that the router cannot connect to the internet and to check cable connections and power cycle the modem/router, which I have done, to no effect.  I have also reset the router via the browser administration page as well as by holding the reset button on the back of the router for 5 seconds.  I've checked the settings on the browser and can't see what is causing the problem.  All my settings are typical, DHCP automatic, WPA TKIP, etc.  I've also tried turning off wireless security to see if that helped, but it did nothing.  I would appreciate any help leading to a solution for this problem!

Posts: 6,365
Registered: ‎09-16-2006

Re: WRT54G Wireless Not Working

[ Edited ]

First of all, in the router, give your network a unique SSID. Do not use "linksys". If you are using "linksys" you may be trying to connect to your neighbor's router. Also set "SSID Broadcast" to "enabled". This will help your computer find and lock on to your router's signal.

Also, in the computer, go to your wireless software, and go to "Preferred Networks" (sometimes called "Profiles" ). There are probably a few networks listed. Delete any network named "linksys". Also delete any network that you do not recognize, or that you no longer use.  Delete your current network (this will remove any old settings).  Reboot computer.  Return to "Preferred Networks" and re-enter your current network info (SSID, encryption (if any), and key (if any) ). Then select your current network and make it your default network, and set it to automatic login. You may need to go to "settings" to do this, or you may need to right click on your network and select "Properties" or "settings".  Reboot computer.  You should connect automatically to your router (it can take up to two minutes).  If you still have trouble, temporarily disable your computer software firewall and try again to connect.

 

Also note:  For WPA (or WPA with TKIP), enter the "key" (sometimes called password or passphrase) into your computer.


If the above does not fix your problem, download and install the latest driver for your computer's wireless adapter.

Message Edited by toomanydonuts on 10-10-2009 03:38 AM
Posts: 4
Registered: ‎10-09-2009

Re: WRT54G Wireless Not Working

I've given my network a unique SSID, and am broadcasting it.  The problem is the router is not even broadcasting anything, and says it is not connected to the internet even though clearly it is since my wired computer accesses the internet through it.  You suggested all sorts of things to do regarding my wireless computer, but I believe the problem is not at my wireless computer since I can take it to locations with wifi and connect to the internet fine.  This is not the initial setup of the router by the way; it had worked before and just mysteriously stopped working a week ago.  I also updated my router's firmware yesterday in response to the connectivity problems to no results.  Thanks for your suggestions, though.
Highlighted
Posts: 4
Registered: ‎10-09-2009

Re: WRT54G Wireless Not Working

I wouldn't double post but I can't edit my previous message.

 

Anyway, I believe I may have located the source of the problem.  Under the Support section of EasyLink Advisor where you can see all your settings, the wireless network's name is set to +wlansetup.register+ and Wireless Network Mode is set to "disable".  

 

 

 

 

 I wonder how this is the case, as when I access my router through the browser, I see this under the wireless tab:

 

 

Any ideas on this?

Posts: 2,517
Registered: ‎09-07-2006

Re: WRT54G Wireless Not Working

It means that your Easy Link Advisor is unable to update the wireless settings of the Router. Its better to change the Settings on your Router Manually.

 

Login to the Router setup page and click on the wireless tab and below you need to change the Wireless Channel to 11-2.462GHz and let the SSID broadcast should be Enable and click on Save Settings. 

 

Then you need to click on the sub tab under wireless "Wireless MAC Filter" and if its enable , Disable it and click on Save Settings.... 

 

Click on Advanced Wireless Settings


Change the Beacon Interval to 75 >>Change the Fragmentation Threshold to 2304, Change the RTS Threshold to 2304 >>Click on "Save Settings"...


Now see if you can locate your Wireless Network and attempt to connect...

Posts: 6,365
Registered: ‎09-16-2006

Re: WRT54G Wireless Not Working

After a firmware upgrade, you must reset the router to factory defaults, then setup the router again from scratch.  If you have not done this since the last firmware upgrade, please do this now and see if it corrects your problems.  If you saved a router configuration file, DO NOT use it.
Posts: 4
Registered: ‎10-09-2009

Re: WRT54G Wireless Not Working

Thanks for everyone's help, but I figured it out, sort of.  My router is working again after I used EasyLink Advisor 3.0 (was using 1.6 or some older version before), and my wireless pci antenna somehow got loose as well, which didn't help at all. 
Posts: 12
Registered: ‎10-11-2009

Re: WRT54G Wireless Not Working

[ Edited ]
Gollum , thanks man, I am having the same prob. with my Linksys Wireless N broadband router model WRT160N. I changed my settings to that hope it works.
Message Edited by Edward78 on 10-11-2009 10:16 AM
Message Edited by Edward78 on 10-11-2009 10:17 AM