Reply
AHarney
Posts: 1
Registered: ‎02-24-2009

WRT54G and Vista x64 drops

To resolve this issue, disable the DHCP BROADCAST flag in Windows Vista. To do this, follow these steps: Click Start, type regedit, If you are prompted for an administrator password or for confirmation, type your password, or click Continue. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID} [this is the first numeric string startins with {90...

Right click on DhcpConnEnableBcastFlag, Modify, and set the value to 0 (numeric zero). I then rebooted.

I have not had a drop in 24 hours. Hope it continues. Found this at: support.microsoft.com/kb/928233 " This issue occurs because of a difference in design between Windows Vista and Microsoft Windows XP Service Pack 2 (SP2). Specifically, in Windows XP SP2, the BROADCAST flag in DHCP discovery packets is set to 0 (disabled). In Windows Vista, the BROADCAST flag in DHCP discovery packets is not disabled. Therefore, some routers and some non-Microsoft DHCP servers cannot process the DHCP discovery packets."
binky
Posts: 2,613
Registered: ‎09-07-2006

Re: WRT54G and Vista x64 drops

Wow thats great, i will really try that on my machine. Thankx for your Post.