Reply
Sniperhank
Posts: 1
Registered: ‎09-23-2009

WRT54G and "Strict NAT"

Ok, I've been trying for months to get my WRT54G to work properly with my Xbox 360.  This thing has been very frustrating.  I have enabled UPnP, port forwarding, everything that I could think of and used multiple methods that are "sure things" from this site and many others.  I still get told I am using a strict NAT.  This has got to the point of flat retarded.  Microsoft tells me its a Linksys problem, Linksys tells me it is a Microsoft problem.  When I connect straight into my modem I have no issues so this is a problem with the router.
Ricewind
Posts: 3,013
Registered: ‎09-07-2006

Re: WRT54G and "Strict NAT"

As you have already opened the Ports on your Router for your XBOX and enable the UPnP on your Router and still you are getting NAT Strict on your Router, this might be due to incorrect settings set on your Router and on your XBOX. Here are some of the settings you can change on your router as well as on your XBOX and check if this solves your Problem.

 

Open an Internet Explorer browser page on your wired computer(desktop).In the address bar type - 192.168.1.1 and press Enter...Leave Username blank & in Password use admin in lower case...

On the set-up tab change the MTU Size to 1365 and click Save Settings...

Click on "Administration" tab and disable the option UPnP and click Save Settings...

Click on "Applications and Gaming" tab and then click on "Port Range Forwarding" subtab...

1) On the first line in Application box type in ABC, in the start box type in 53 and End box type in 3074, leave the protocol as both and under ip address type in 192.168.1.20 and check the enable box, click Save Settings once done...

2) Once you return to the set up page click on the Security tab and uncheck Block Anonymous Internet Requests and click on Save Settings...

3)Click on the Status tab and take note of DNS1 and DNS2 Addresses...

4) Goto the XBox Network Settings and IP Address Settings and select manual IP Settings and assign the following on your Xbox IP Address :- 192.168.1.20, Subnet Mask :- 255.255.255.0, Default Gateway :- 192.168.1.1...

5) Also assign the DNS Addresses on the Xbox.Use DNS1 and DNS2 Addresses you took note off of the router status tab as Primary DNS & Secondary DNS for the xbox...

6) Turn off your modem, router, and Xbox...Wait for a minute...

7) Plug the modem power first, wait for another minute and plug the router power cable, wait another minute and turn on the Xbox and test it...it will connect...

 

If this dosent solves your problem then you need to upgrade the firmware of your Router.... Go to the Linksys website and download the updated firmware for your Router.. 

 

Follow these steps to upgrade the firmware on the device : -


Open an Internet Explorer browser page on a computer hard wired to the router...In the address bar type - 192.168.1.1...Leave the Username blank & in Password use admin in lower case...
Click on the 'Administration' tab- Then click on the 'Firmware Upgrade' sub tab- Here click on 'Browse' and browse the .bin firmware file and click on "Upgrade"...
Wait for few seconds until it shows that "Upgrade is successful"  After the firmware upgrade, click on "Reboot" and you will be returned back to the same page OR it will say "Page cannot be displayed".

Now reset your router :


Press and hold the reset button for 30 seconds...Release the reset button...Unplug the power cable from your router, wait for 30 seconds and re-connect the power cable...Now re-configure your router...