Reply
MoonFallsDown
Posts: 3
Registered: ‎10-30-2009

WRT54G doesn't see my cable modem

I have a Linksys WRT54G that worked flawlessly with my parents' cable modem. They got a fancy new FIOS thing that has built in wireless, so the WRT54G was handed down to me. I currently have an older Netgear router that works, but it's been dropping wireless signals periodically (and it's only 802.11b) so I figured I would replace it with the WRT54G.

 

I replaced the Netgear router with the WRT54G, using all the same cables (except power) that I know are working, and the "Internet" light on the front of the WRT54G does not light up. (Linksys setup also is unable to detect my internet connection.) Everything works a-ok with my old Netgear router.

 

Things I have tried:

- Power cycles in various orders

- Updated firmware

- Different cables

- MAC address clone

- Plugged the WAN port into another active ethernet port (I do get an Internet light in this case, which suggests to me that the WAN port is not dead)

 

The only time I don't get a connection on the WAN port is when it's plugged into the modem, but the modem works fine plugged into both my computer and another router.

 

I'm stumped.  Any thoughts?

 

(The router is a WRT54G v8.  Cable modem is a Motorola Surfboard SB5120 from Cox Communications.)

helm
Posts: 3,650
Registered: ‎09-07-2006

Re: WRT54G doesn't see my cable modem

Have you tried connecting a different cable from the Modem to the Linksys Router on the WAN Port. You can use the cable which came along with the Linksys Router and check if the WAN Port lights on your Router lid.
khangxxx
Posts: 3
Registered: ‎11-01-2009

Re: WRT54G doesn't see my cable modem

I use WRT54G version 7, after I use firmware 8.2 to upgrade my WRT54G, it doesn't work anymore. Please kindly show me where I can upgrade firmware of WRT54G version 7.
MoonFallsDown
Posts: 3
Registered: ‎10-30-2009

Re: WRT54G doesn't see my cable modem

[ Edited ]

I've tried a handful of different cables, all with the same result.

 

I do not however have the original ethernet cable that came with the router.  I don't suspect it would be any different than the respective cable that came with my old router however.

Message Edited by MoonFallsDown on 11-02-2009 08:14 AM
MoonFallsDown
Posts: 3
Registered: ‎10-30-2009

Re: WRT54G doesn't see my cable modem

[ Edited ]

Bumping this because I got it to work ... umm, sorta.

 

I flashed DD-WRT onto the Linksys router.  Now, if I plug it into one of the functioning ports on the back of my old Netgear router, the WRT54G works fine.  But if I plug it directly into the cable modem, it still can't see the cable modem.

 

I don't get it.

Message Edited by MoonFallsDown on 12-13-2009 08:55 PM