Reply
1234567890
Posts: 3
Registered: ‎10-02-2008

WRT54G2 Hangs at 99% on "WiFi Protected Setup"

Hello. I hit the wifi protected setup button on my router, now every time I try to navigate to the "wireless" tab in the web-based configuration screen a frame comes up that says

"Searching for your client device.
Please wait...
If you haven't clicked on the Wi-Fi Protected Setup button on your client device, please do so now.
99%"

and it hangs on 99% forever, with no way to cancel it. Is there any way to cancel this WITHOUT doing a hard reset of the router?

As a temporary workaround, I used "View -> Page Style -> No page style" in firefox so i could select manual setup and save the settings, but even with manual setup checked (and the ability to successfully configure wireless settings with the style sheet turned off), the

"Searching for your client device.
Please wait...
If you haven't clicked on the Wi-Fi Protected Setup button on your client device, please do so now.
99%"

frame still pops up with the basic page style turned on (thus every option is unclickable), and is still visible with the CSS turned off.

There is no option to cancel setup, and any other topic on this support forum just recommends a hard reset.

Is there any other way to deal with this other than a hard reset?
Will this be fixed in a future firmware version?

This is pretty problematic because without a "Wifi Protected Setup" client device, the router seems to be stuck in some sort of infinite loop with no way to break out of it.

Thank you.
davao_music
Posts: 60
Registered: ‎05-18-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

hmmm.. even if you powercycle the router, it will still do that.
 
can you click on the administration tab? try to just upgrade or reload the firmware of the router even if you don't need to.
 
or just back up the router's settings and reset the router (i know you don't like that)
you can simply make a back up file of your router's settings and restore it simply by going to the administration tab and config management subtab.
Wizzard
Posts: 3,025
Registered: ‎09-07-2006

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

Reset the router back to factory defaults and reconfigure it and this time set up the security manually. 
1234567890
Posts: 3
Registered: ‎10-02-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

So, essentially, Wifi Protected Setup is a feature so broken that it requires a complete factory reset? How is there not a warning about this above the button in the middle of the router?

I set up the security manually in the first place. Because of linksys's poor design, it's more convenient for me to just remove style sheets when I view the setup page so I can actually change options instead of resetting the entire router. Why is there not an option to cancel the Wifi Protected Setup?

Would your solution to a leaky faucet be to demolish the whole house and rebuild it? If there was a typo in your post, would you erase the whole thing and type it all out again?

I read the other posts on this subject before I posted. I specifically asked in my post if there was any way other than a hard reset and if it would be fixed in a future firmware revision. Those were my questions. I already have a temporary workaround that gets what I need done without me losing all the options I have set.

When will this be fixed?
1234567890
Posts: 3
Registered: ‎10-02-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

Any word on when the much needed "close this window" or "cancel" function will be implemented?
checkin
Posts: 1
Registered: ‎11-17-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

 

I installed WRT54G2 yesterday and am getting the same problem... Its hanging with the message "WRT54G2 Hangs at 99% on "WiFi Protected Setup". What needs to be done other than resetting?

Would you be able to share the temporary workaround that you found? I'm struck and not able to configure using that 'Wireless' tab....

Appreciate your help.

 

jutd
Posts: 1
Registered: ‎11-17-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

Hey i'm having the same problem I just my router this weekend the WRT310N. I get that same 99% hang message and can't do anything to avoid it. I've reset my rounter still appears. Very frustrated. Does anyone know how to work around this or fix this problem?
MWU
MWU
Posts: 1
Registered: ‎11-29-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

I just made it.

I disabled CSS, then check the manual wireless configuration, I also disabled "SSID broadcast" (I guess you do not need to do so), then I power off and power on the router. That anonying message is disappered. Everything seems fine now.

 

Hope this helpful

Gys
Gys
Posts: 2
Registered: ‎11-25-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

Got the following also:

 

Searching for your client device.

Please wait...

If you haven't clicked on the Wi-Fi Protected Setup button on your client device,

please do so now.

Stops at 99%

Goosey
Posts: 1
Registered: ‎12-26-2008

Re: WRT54G2 Hangs at 99% on "WiFi Protected Setup"

I had the same issue.  I was able to resolve this by upgrading the firmware of my router.

When you go to the Router administration page at 192.168.1.1 and look to the top right corner.  You can see the firmware version.

Mine was 1.0.00 before I upgraded my firmware and 1.0.01 after.

 

After this the message was nolonger seen.

 

 NEW firmware - 1.0.01 (Buid 3) 4/29/2008

http://www.linksys.com/servlet/Satellite?c=L_CASupport_C2&childpagename=US/Layout&cid=1175242897803&... 

My router is a WRT4G2.

 

Hope this helps!