Posts: 3
Registered: ‎05-12-2009

WRT54G2 v1 Wireless Not Working

Hello! I purchased the WRT54G2 yesterday so I could connect multiple devices to the internet (2 of which can use wireless). I have attempted to get the wireless working but I have not solved the problem. I have talked to two Linksys representatives and they have not been able to solve the problem. My laptop which runs on Ubuntu and my iPhone do not detect the SSID of my wireless network while being able to detect other networks that are not mine. Does anyone have any suggesstions to fix this issue?
Posts: 72
Registered: ‎04-28-2009

Re: WRT54G2 v1 Wireless Not Working

If your able to detect other networks but cant detect your network then maybe it has something to do with the firmware of the router.. Try also to check the router's set-up page, because maybe the SSID Broadcast is disabled.
Posts: 2,324
Registered: ‎09-07-2006

Re: WRT54G2 v1 Wireless Not Working

As you have tried all the settings on your Router, I think first you can do is, Upgrade the firmware of your Router, which you can Download and save it on your Computer.


Follow these steps to upgrade the firmware on the device : -
Open an Internet Explorer browser page on a computer hard wired to the router...
In the address bar type - the username blank & in password use admin in lower case...
Click on the 'Administration' tab- Then click on the 'Firmware Upgrade' sub tab- Here click on 'Browse' and browse the .bin firmware file and click on "Upgrade"...Wait for few seconds until it shows that "Upgrade is successful"  After the firmware upgrade, click on "Reboot" and you will be returned back to the same page OR it will say "Page cannot be displayed".

Now reset your router :
Press and hold the reset button for 30 seconds...Release the reset button...Unplug the power cable from your router, wait for 30 seconds and re-connect the power cable...Now re-configure your router...


Here are the wireless settings which you can set on your Router, i think this might solve your problem. 


Open an Internet Explorer browser page on your wired computer(desktop).In the address bar type - and press Enter...Leave username blank & in password use admin in lower case...
For Wireless Settings, please do the following : -
Click on the Wireless tab
-Here select manual configuration...Wireless Network mode should be mixed...
-Provide a unique name in the Wireless Network Name (SSID) box in order to differentiate your network from your neighbours network...
- Set the Radio Band to Wide-40MHz and change the Wide channel to 9 and Standard Channel to 11-2.462GHz...Wireless SSID broadcast should be Enabled and then click on save settings...
Please make a note of Wireless Network Name (SSID) as this is the Network Identifier...
For Wireless Security : -
Click on the Sub tab under Wireless > Wireless Security...
Change the Wireless security mode to WPA, For Encryption, select AES...For Passphrase input your desired WPA Key. For example , MySecretKey , This will serve as your network key whenever you connect to your wireless network. Do NOT give this key to anyone.

NOTE : Passphrase should be more that 8 characters...

Click on Advanced Wireless Settings
Change the Beacon Interval to 75 >>Change the Fragmentation Threshold to 2304 Change the RTS Threshold to 2307 >>Click on "Save Settings"...
Now see if you can locate your Wireless Network and attempt to connect...

Posts: 3
Registered: ‎05-12-2009

Re: WRT54G2 v1 Wireless Not Working

I have done everything you have said great_white, except the part about setting the wide channel since under the Basic Wireless Settings there is only the option to change the wireless channel and there is nothing about the Radio Band or the Wide Channel. My wireless still does not work despite all these changes. Could it just be that the router is faulty? Thanks for all your help!
Posts: 3
Registered: ‎05-12-2009

Re: WRT54G2 v1 Wireless Not Working

Has anyone else encountered a similar issue with this router?