Posts: 1
Registered: ‎06-04-2008

WRT54GC - unable to connect to router setup page after firmware update

I bought my router 3 or 4 years ago and have NEVER updated the firmware, so I decided to do it last night since I was having trouble forwarding some ports. I went to the Linksys website and followed the directions TO THE LETTER. I am now running firmware v1.05.7. At least I think I am.
Once I finished the firmware update, the trouble began.
The setup:
2 computers. 1 has a wired ethernet card, the other has a Wireless-G adapter.
1 Linksys wireless router.
1 DSL modem from a company called TDS Telecom.
I AM able to connect to the internet via the computer with the wired connection. The cable runs from my computer into the router and the DSL modem is also connected to the router.
Now, I SHOULD be able to type in and connect to the router's setup page, but it cannot connect. However, there IS a setup page built into the DSL modem at IP address that I CAN connect to.
Things I have tried:
- Reset both the router and modem. Still unable to connect.
- Reset them in reverse oder. Still unable to connect.
- Used ipconfig /release and /renew to try to grab a new IP address. The current IP address listed in the network properties is Since the third set of numbers is a "0" instead of a "1", that would seem to imply that my computer is being fed its IP address by the DSL modem and NOT the router, so I tried removing the DSL modem from the equation.
- Unplugged the DSL modem. Tried ipconfig /release and /renew. The /release went just fine, but the computer hung on the /renew as there was apparently no IP address to /renew to.
- Pressed the rest button on both devices. Neither one of them turned off and on or cycles their lights or anything apparent (and I pressed the buttons very firmly). Tried accessing again and still NOTHING.
I am NOT behind any firewalls. I am NOT running any kind of virus protection. I am using Windows XP. I made sure that I was actually UPGRADING my firmware and NOT downgrading it. The previous version was MUCH lower than v1.05.7.
Obviously, the router IS routing SOMETHING, since I am able to connect to the internet through the cabled computer, but it isn't broadcasting any kind of wireless signal or else my other machine could see it. Can anybody figure out why I am unable to connect to the router's setup page at
If anybody out there can solve this dilemma for me, it'd be much appreciated. Thanks in advance.
Posts: 2,613
Registered: ‎09-07-2006

Re: WRT54GC - unable to connect to router setup page after firmware update

Hey as you said that you already upgraded the firmware of the router for 30 secs try upgrading the firmware of the router & make sure you are resetting the router once again tightly because the reset button for this router is deep inside &  then do a complete network power cycle & it should definately work!!