Showing results for 
Search instead for 
Do you mean 
Reply
pauldunbar
Posts: 5
Registered: ‎12-15-2010

WRT54GL & Cisco 7960G VoIP Phone

[ Edited ]

Hello fellow Cisco users,

 

I use a Cisco VoIP phone, the ubiquitous 7960G IP phone, and have no problem using it with non-Cisco routers.  The phone does not seem to work with the Cisco WRT54GL router under the setup I have as explained below.

 

I usually connect my Cisco IP phone directly to my laptop's ethernet port giving the phone a shared internet connection.  This arrangement works fine with two non-Cisco routers I've used.  With the Cisco WRT54GL router however, the phone cannot get an IP configuration, even after opening the needed ports, leading me to believe the problem is likely to be something with the router.  I have also tried setting up a DMZ for the router without success.  The biggest problem is that the phone uses DHCP (which I also prefer) and the DMZ and port forwarding features require I set the phone's IP address.

 

I would greatly appreciate any thoughts on how to resolve this.

 

Many thanks for suggestions.

 

PS:  I forgot to add that the phone works (i.e. receive and make calls)  when plugged via ethernet cable into the router.  Apart from the problem of having an ethernet cable running across a room, this setup also has some features missing like date and time so calls aren't stamped.

scrooge
Posts: 2,610
Registered: ‎09-07-2006

Re: WRT54GL & Cisco 7960G VoIP Phone

The phone is working when you connect the phone to the router with the Ethernet cable. I think the DHCP on the router is working properly.

When you connect the phone to the computer with the Ethernet cable, it is not getting IP address. I think there might be issue with the Internet connection sharing on your computer. Your phone is not getting IP address that means the phone is not communicating with the router.

Try assigning a static IP address on your phone and see if that works.

pauldunbar
Posts: 5
Registered: ‎12-15-2010

Re: WRT54GL & Cisco 7960G VoIP Phone

Thanks for the response.
The internet connection sharing settings (ICS) I have work fine with both of the other routers I've used without any problem or adjustment to the ICS or routers.
Since I was hoping to keep the DHCP settings on the phone (to avoid having to make config adjustments for different router environments when I travel), I had't tried the static IP suggestion.  I'll give it a try and respond whether it works.
Thanks.
pauldunbar
Posts: 5
Registered: ‎12-15-2010

Re: WRT54GL & Cisco 7960G VoIP Phone

I tried setting a static IP address on the phone and opened the ports but the Cisco IP phone failed to configure.

 

To ensure the problem is not with the Cisco phone or my PC's ICS, I also tried the SIP client on a Nokia phone (which works with the other two routers I've used and can browse the web via the WRT54GL) that can't seem to connect the SIP client.

 

Last, I spoke with me ISP, which further confirmed that the ports needed are already open on the ISP's side.

 

The issue seems to be with the WRT54GL's handling of VoIP SIP.

 

Any other suggestions are appreciated.  Thanks. 

Mort
Posts: 3,636
Registered: ‎09-07-2006

Re: WRT54GL & Cisco 7960G VoIP Phone

I think your phone is not getting IP address when it is connected to the computer. But when you connect it directly to the modem, it works.

You can try to upgrade/re-flash the firmware on your router.

Connect the computer with the Ethernet cable to the router.
Download the latest firmware from Linksys website and save it on your computer. Open the setup page of the router. Click on Administration tab and go to Firmware upgrade sub tab. Browse the firmware file that you have already downloaded and upgrade it on your router.
After upgrading the firmware on the router, it is recommended that you should reset the router and reconfigure it. Press and hold the reset button on the router for 30 seconds. Release the reset button and wait for 30 seconds. Power cycle the router and reconfigure it.
Also try to change some advanced wireless settings on the router. Click on Wireless tab and go to Advanced wireless settings. Change the Beacon interval to 75, RTS threshold to 2307 and fragmentation threshold to 2306. Save the settings.

pauldunbar
Posts: 5
Registered: ‎12-15-2010

Re: WRT54GL & Cisco 7960G VoIP Phone

Thanks for the suggestion, Mort.  Before your message, I upgraded the WRT54GL to the latest firmware and got the Nokia SIP client working (for the most part), without changing the advanced wireless settings.

 

After making both firmware and advanced wireless settings changes, the IP phone still fails to connect via ethernet.  To again ensure the problem is not specific to my XP laptop, I attempted to connect via a Vista laptop's ethernet but got the same failed results.

 

Any other suggestions are much appreciated.  Thanks.

pauldunbar
Posts: 5
Registered: ‎12-15-2010

Re: WRT54GL & Cisco 7960G VoIP Phone

[ Edited ]

At long last I found the solution to this vexing problem.  The problem seemed to have stemmed from the router.

 

CONCLUSION

 

From this experience, it may be best to first place new routers through a battery of tests to see if they're compatible with current and upcoming technologies (e.g. VoIP, IPv6) and if not taking it immediately back to the seller for a full refund to test another.

 

Good luck.

 

(Mod note: Edited for guideline compliance.)