Reply
Sucka
Posts: 3
Registered: ‎02-10-2007

WRT54GS v1.0 Drops Connection under Vista, Fix?

Since an upgrade to vista my router has been droping the internet connection at random times, and quite frequently. Sometimes i will be connected for hours, other times it will drop every 5 minutes. This problem did not exist under XP, nor does the net cut out on other XP based machines. Occasionally it will drop the connection, and not see any networks (there are several in my area). Other times it will show my network with the name "Unnamed Network" and not allow me to connect to it. I'm thinking there is an issue with Vista autodetecting the network? Went to look for the latest firmware, but seems linksys is almost a year behind since their last release (i updated anyways). Also why is there no tech support email clearly posted on their site to address them with this question? Thanks for any help you can offer.
Klatch
Posts: 2,829
Registered: ‎09-07-2006

Re: WRT54GS v1.0 Drops Connection under Vista, Fix?

Hi… This is nothing to do with the router. Do not change anything on this router, it is properly configured and is working. This is an Issue where with your wireless adapter drivers. Whenever you are disconnected you cannot see any network because the adapter is not working. And that’s why your other computers are unaffected while this is not working.

Sucka
Posts: 3
Registered: ‎02-10-2007

Re: WRT54GS v1.0 Drops Connection under Vista, Fix?

Upon further review, every time my internet cuts out on my Vista laptop, it is also cutting out on my wife's XP laptop. The internet does NOT drop on my wired XP machine. They both drop at the same time, what does this indicate? Again this is new since adding a vista computer to the network, this router has been rock solid for well over a year otherwise.

I also went through tech support (before i realized all wireless was dropping at the same time) and they confirmed this router should work with Vista.

Is it just bad luck my router went bad at the same time i installed Vista? Or is Vista somehow affecting this? And to the above poster, thanks for the advice, but i swapped out my internal Intel 3945ABG adapter with my other laptop (same adapter of course) and it did not change anything. I'm led to believe this is Vista borking it, or my router just went/is going bad?

Anyone?
Klatch
Posts: 2,829
Registered: ‎09-07-2006

Re: WRT54GS v1.0 Drops Connection under Vista, Fix?

Hi… If both the laptops are losing the connection then there is some wrong with the settings on the router. Try this. Reduce the MTU to 1365, beacon to 50 and RTS and Fragmentation Threshold by 40 each. Upgrade the firmware of the router, if needed. Reset and configure after upgrade.

Sucka
Posts: 3
Registered: ‎02-10-2007

Re: WRT54GS v1.0 Drops Connection under Vista, Fix?

What do these settings change exactly? I do have the latest firmware, i have even tested another Linksys router and have the same problem. I will test those settings next time the net starts cutting out.

Thanks for the reply.