Showing results for 
Search instead for 
Do you mean 
Reply
scrilla
Posts: 2
Registered: ‎12-12-2007

WRT54GX2 slow wireless 5.5 mbps speed help please

So I just received my WRT54GX2 and got it hooked up. Here are some details of my equipment which are all experiencing the same issue while connected via wireless.
 
1 Dell Inspiron wireless G. (updated latest driver)
1 Toshiba laptop wireless G (not sure on driver yet)
1 custom tower with wireless G (updated latest driver)
WRT54GX2 ver 2 with firm ware 1.00.08 (just updated)
Comcast 6 Meg cable internet service with Motorolla cable modem
 
 Here is the problem I am experiencing.
 
After configuring the WPA2/TKIP settings and getting everybody logged on, the wireless connectivity speed (reported via the windows XP wireless utility) indicates connection speeds of 5.5 Mbs. If I disable the adapter and re-enable it, it connects and is at 54 Mbps for about 1 second, then rapidly drops down to the 5.5 which is where it stays. This problem is replicated on all 3 PC's on the wireless. I have tried adjusting the beacon interval down to 50, even went down to 10 with no result. I changed the RTS threshhold to 2304. Tried setting the transmission rate from auto to 54 Mbps. I tried adjusting the RWIN settings on my PC as suggested in another post here where somebody was experiencing a similar problem. I have installed the Microsoft WPA2 patch (893357) and that made no difference either. I have switched to G only instead of mixed mode. Tried channels 1, 11, 7, 6, and probably most of the others. Moved the router around to different locations in the room. Even sitting within arms reach of it, I still only see the 5.5 Mbps (I have full signal strength BTW). I ran netstumbler and found very few wireless networks within range. And the ones that were had very weak signals. Short of unplugging my cordless phone, I am at a loss of things to try. I may reset the router and try a new config from scratch, but if there is any help on this subject it would be greatly appreciated.
 
:smileymad:
 
Thanks
toomanydonuts
Posts: 6,365
Registered: ‎09-16-2006

Re: WRT54GX2 slow wireless 5.5 mbps speed help please

[ Edited ]
After a firmware upgrade, you must reset the router to factory defaults, then setup the router again from scratch.  If you have not done this since your last firmware upgrade, please do this now.   If you saved a router configuration file, DO NOT use it.
 
There are many causes for poor wireless connections, and many solutions:

First of all, give your network a unique SSID. Do not use "linksys". If you are using "linksys" you may be trying to connect to your neighbor's router. Also set "SSID Broadcast" to "enabled". This will help your computer find and lock on to your router's signal.

Poor wireless connections are often caused by radio interference from other 2.4 GHz devices. This includes wireless phones, wireless baby monitors, microwave ovens, wireless mice and keyboards, wireless speakers, and your neighbor's wireless network. In rare cases, Bluetooth devices can interfere. Even some 5+ GHz phones also use the 2.4 Ghz band. Unplug these devices, and see if that corrects your problem.

In your router, try a different channel. There are 11 channels in the 2.4 GHz band. Usually channel 1, 6, or 11 works best. Check out your neighbors, and see what channel they are using. Because the channels overlap one another, try to stay at least +5 or -5 channels from your strongest neighbors. For example, if you have a strong neighbor on channel 9, try any channel 1 through 4.

Also, try to locate the router about 4 to 6 feet above the floor, in an open area. Do not locate it behind your monitor or near other computer equipment or speakers. The antenna should be vertical.

Also, in the computer, go to your wireless software, and go to "Preferred Networks" (sometimes called "Profiles" ). There are probably a few networks listed. Delete any network named "linksys". Also delete any network that you do not recognize, or that you no longer use. If your current network is not listed, enter its info (SSID, encryption (if any), and key (if any) ). Then select your current network and make it your default network, and set it to automatic login. You may need to go to "settings" to do this, or you may need to right click on your network and select "Properties" or "settings".

If the above does not fix your problem, download and install the latest driver for all your wireless cards.  Note that often the speed of your wireless network is determined by the "weakest link" in your system.  You might want to try to isolate the problem by turning on each wireless computer separately, then two at a time.  You might be able to tell which computer is bringing down your wireless speed.
 
If you still have trouble, try the following.

For wireless g routers, try setting the "Transmission Rate" to 54 Mbps. For wireless n routers, try setting the "n Transmission Rate" to 162 Mbps, and the (wireless g) "Transmission Rate" to 54 Mbps.

Hope this helps.


Message Edited by toomanydonuts on 12-12-2007 11:09 PM
scrilla
Posts: 2
Registered: ‎12-12-2007

Re: WRT54GX2 slow wireless 5.5 mbps speed help please

[ Edited ]
Thanks for the reply. I saw your suggestions posted in other posts of this nature and made sure to try all of the items you listed, including the hard reset and fresh config build after the firmware upgrade.
Sadly to say, after a few chat sessions with Linksys tech support, they deemed the router defective and I'm now sending it back via an RMA. Hopefully the replacement one will not exhibit these problems.
 
Wish me luck!


(Mod Note: Edited due to non-compliance of forum guidelines.)


Message Edited by giantherockstar on 12-13-2007 06:34 AM



Message Edited by giantherockstar on 12-13-2007 06:36 AM