Reply
Highlighted
Posts: 2
Registered: ‎02-06-2009

WRT610N NAS NTFS issue for deleting directory

[ Edited ]

Dear all,

 

I got one issue with the WRT610N and the NAS feature. This is really a nightmare. I have been looking everywhere, I found people with the same issue but never find any solution.

 

I am running Vista on a laptop connected to the WRT610N via the 802.11n link but the issue is not here.

I have a hard drive of 40GB (but same issue exist with another drive of 500GB) plug to the USB port. I can read all file without any issue. I can also add file without any problem. The problem come when I try to delete some directory. In this case I got the an 0x8007045D Error indicating that I need to have the right permission for doing this. However I do not have any issue in deleting files. In case I delete all files from a directory I can't delete the directory without the error. I map the drive to the windows explorer with the admin account which give read and write access.

 

 Without this fix the NAS feature can only be used in read only!

 

Could you let me know if you had the same issue? If you solve this could you post the way to fix it? or maybe am i doing something wrong?

 

Your help will be very appreciatated.

 

Regards,

 

 

 

PS: I am also running the latest firmware (v1.00.02 B10). The problem was also present with previous software.

 

 

 

 

 

(Mod note: Edited post for guideline compliance. Thanks!)

Message Edited by JOHNDOE_06 on 03-22-2009 10:28 AM
Posts: 11
Registered: ‎09-07-2008

Re: WRT610N NAS NTFS issue for deleting directory

I have written of this issue before.  I'm surprised no one has submitted a reply to your question.  But basically the answer that I have come to accept is that there is no current solution to the NTFS issue for deleting directories.  You can delete all the files within a directory and then be able to delete the directory, but you cannot delete a directory that contains files.  This is an NTFS compatibility issue with the WRT610N (and I've read that other hardware has this same issue) that everyone is hoping will soon be fixed with a firmware upgrade.  I've have just learned to cope with this inadequacy.  I don't often have to delete things, but when I do, it is just a pain and time sinker.  I would just continue to check the firmware support page for a new version of firmware that may fix it and the forums for possible solution that some great mind might come up with. 

 

If anyone has anything to add, or correct ... have at it my friends.

Posts: 2
Registered: ‎02-06-2009

Re: WRT610N NAS NTFS issue for deleting directory

I have been in contact with the on-line linksys support last week-end. They said that I should have a feedback of the issue by e-mail. I received the e-mail today from lynksys UK support. They asked for more details of the issue and then I just provided them more details of the issue including screenshots. I hope this will be fixed otherwise the NAS feature is just useless for me. I use the NAS for automatic backup which synchronizes files and therefore delete directories when they have been delated in the source. I got similar issue when using iTunes from MP3 database. I guess that the application try sometime to create directories when adding photo album to MP3 database. So basically a non reliable NAS is just useless. I found the WRT610N very attractive in terms of features, i.e. everything I need in single box but very disappointed of the various issue I had on the router regarding the DLNA issue, at least with the previous firmware.

 

Having the hard drive in FAT32 instead of NTFS is also not a good option. It took 8 hours to copy about 400 GB of data on my western digital 2.5" (500 GB drive) when the drive is format as NTFS and attached to my PC. When using  FAT32 it took 5 to 5 days! FAT32 is very old and not reliable format (no journal file). NTFS is said as supported in other linksys product so I guess that it shoud be possible to have it on this prodcut. It sure that for a long time NTFS support on linux was not always easy for write access but I think that things have changed since that time. In case NTFS would not be possible they should provide other reliable and fast drive format such as Linux EXT2/EXT3 formant. However, I tried those format and it do not work. That is quite strange since this is a native linux format and the router is probably running on linux system.

 

For your information, I also had some disk corruption when I did some delation of files/directory with a FAT32 drive. It was less reccurent than NTFS but still not reliable. However I did not try the latest firmware with a FAT32 drive.

 

I will let you know when I will have feedback. If anybody has similar issue please just mention it here, at least we and linksys can be aware of the situation. Linksys should also take this opportunity to listen to their customers and enhance their product. I really believe that this product has been put on the market without the proper validation and I am suprise that it takes so many months to have updated firmwares.We can understand that bug could exist, but they should fixe it.

Posts: 3,025
Registered: ‎09-07-2006

Re: WRT610N NAS NTFS issue for deleting directory

Yes, you should try the latest firmware with a FAT32 drive and see what happens...I think this a firmware issue with WRt610N router's...
Posts: 1
Registered: ‎05-19-2009

Re: WRT610N NAS NTFS issue for deleting directory

[ Edited ]

I was just curious if linksysuser heard back from linksys support. I'm having the same isssue I can't delete directories because I get a permission error. When I do a refresh the directory appears to be gone just to show up later. I confirmed this by removing the USB drive from the router and connecting to a pc. I bought this router specifically for backups. As linksysuser stated this issue makes the device unreliable for backups. Wish is think is the dominant reason why  most users got this router. If the nas does not work then the DIR-825 is a better router thats about half the price. I got about 30 days left before I can return the router back to Best Buy. Hopefully, I hear back or at least know that linksys is doing something about the issue. BTW, I read in another forum that using the ftp server you could delete directories. however, when i disconnected the drive and connected to a pc; the directory showed up again. FYI, the disk also got currupted and had to do a reformat. I also noticed some other issues which I will just write down so in case linksys support reads these threads.

 

Details-

Firmware: B10

HDD: WD 500GB (NTFS/FAT32) I tested on both.

Vista Business

I'm logged in as admin, not router admin but the NAS admin so permission should not be an issue.

 

Issues:

1: NAS(USB storagae Device)

  • Delete Issues - Permission Error
  • Files missing - Directory Files magically disapper when accesed via the router (NAS) but show up when connected via a pc. There is a thread on this topic i.e. connected to pc 3000 files show up(Correct) but via the router only 2000 or so show up(incorrect).

2: File Transfer to NAS

  •  Transfering files over to the NAS via Wireless/wired freezes the router i.e. transferred 60GB of Data 56dir 4254 files and router frooze after transferring 5 dir 1000 files. specifically at a file that was 3.20GB. And yes I used a wired connection. Well actually did both I gotta be a thorough tester.

3: FTP Server

  • Delete Issue - Permission Error

 

But on the upside, The router does get good speeds. Smiley Happy so it's not all that bad. However, I need a nas for backups. I hate having to leave my PC on so that my other pc's can be backuped.

 

LinkSys can we please get this resolved the WRT54G was a good router and It's why I choose LinkSys but this is hurting Brand Loyalty. At least let us know your working on it and a possible firmware update ETA?

 

Thanks

JC

Message Edited by jcolo11 on 05-19-2009 10:12 AM
Message Edited by jcolo11 on 05-19-2009 10:18 AM
Posts: 1
Registered: ‎10-19-2011

Re: WRT610N NAS NTFS issue for deleting directory

All,

 

I had this issue with deleting directories as well on my brand new WRT610N with a Samsung G3 drive attached. I think I have found the solution for the problem, and I wanted to share it with you.

 

First the issues I was facing: 

1. Sometimes, unpredictably, the server didn't let me delete directories.

2. Directories that I had tried to delete but didnt succeed in ("cant delete directory") appeared later to be gone anyway. However, later these directories popped up again. Very frustrating.

3. And the most serious issue: my FLAC music files stored on the Samsung drive were slowly but surely corrupted by the WRT610N server. The FLAC files were still readable and playable, but they were truncated at the end (this results in sudden break-off of the music). I was very lucky to detect this issue before I had ripped my entire 1000 CD collection to the NAS! I tested the FLAC files with a test utility see  http://www.vuplayer.com/other.php.

 

The solution:

I am pretty sure that the issue lies in the incompatibility of the NTFS file format with the WRT610N. The Samsung came out of the box in the modern NTFS format, but the server apparently can't manage this format leading to serious issues.

The solution is simply to re-format the disk in FAT32 by the "format" option on the server:

- save anything you want to keep from your harddisk (check that the files were not corrupted!)

- type "wrt610N" in explorer bar, or type the IP address of the server.

- when asked for userID/password, type "admin/admin" (if you didnt change the password before)

- .go to "Storage" tab

- select "format disk" which will reformat the disk in FAT32.

 

Since I did this, everything works flawlessly. I have not experienced issues with the older FAT32, but I know there are some limitations e,g, related to file size (max 4 GB per file?).

 

good luck

Ron