Reply
torabora
Posts: 1
Registered: ‎05-11-2009

When I hook up router through modem, no internet, modem only internet ok

Okay, so we decided to shut off our home phone since everyone only uses cells now.  But wanted to keep our SBC dsl line and upgrade it to the faster connection.  So, phone line gets shut off, no internet for a few hours, as expected, but after 5 hours I called in to tech support at which time they told me they had to walk me through setting the modem back up again so we could get back online.  First question, is your computer hooked up to the internet via a router?  They required that I disconnect the router before they could proceed because they do not support routers, unless it is one of theirs.  No other options given.  So I went through the process with them and was back online.  But only I, on the main computer, could get back online since the router was not connected.  We have two other computers here, both use wireless adapters, one is a desktop in another room the other is a laptop. 

Now, when I go in and set up all the wires as instructed, all the lights come on properly indicating that I should be connected, but whenI try to pull up a page or do anything that requires me to be connected, I'm getting error messages that I can't connect to the internet.  When I go into the control panel and look at the network connections, says I'm connected.  

Everything is fine if I just want to get internet access for this one computer and only use the modem.  But if I want to get everyone else online using my Linksys WRT300N Wireless-N Broadband Router then I have problems and absolutely no internet for anyone.  

Any help appreciated.  I've got a child who homeschools and does all of her work online so it is imperative that we resolve this as soon as possible.  

toomanydonuts
Posts: 6,365
Registered: ‎09-16-2006

Re: When I hook up router through modem, no internet, modem only internet ok

With most SBC (AT&T) setups, the modem does the PPPoE login for you.  The modem can do this because it is actually a modified modem-router.  So in most cases, your WRT300N would need to be set to an "Internet Connection Type" of  "DHCP - automatic"  (not PPPoE).

 

To make this change in your router, power down your entire network.  Disconnect the WRT300N from the modem and all other devices.  Next, using an ethernet cable, connect one computer to a LAN port on the WRT300N.  Power up the WRT300N.  Power up your computer.  Login to the WRT300N at 192.168.1.1 , then set the "Internet Connection Type"  to  "DHCP - automatic".  Click on the "Save Settings"  button, then wait (3-60 seconds) for the screen to refresh.  Power down the WRT300N and your computer.

 

Next, using an ethernet cable, connect the modem to the Internet port of the WRT300N.  Leave one computer wired to a LAN port on the WRT300N.  If your modem has a USB port, do not connect anything to it.   Power up your modem and allow it to fully boot.  Power up your WRT300N and allow it to fully boot.  Power up your computer.  Now try your Internet connection.  It should work.

 

If you still have trouble, please do the following:

 

1)  Please state the make and exact model number of your modem  (not the WRT300N).

2)  Please do the following test:

 

Power down your entire network.  Using an ethernet cable, connect your modem directly to your computer.   (We will not be using the WRT300N during this test.)   Power up your modem and computer.  If your computer has a wireless adapter, turn it off.   Verify that you have a working Internet connection, then do the following:

 

Go to "Start" > All Programs > Accessories > Command Prompt.
A black DOS box will appear. Type in "ipconfig /all" (with no quotes), then hit the Enter key.  Copy the results to your next post.  To do the copy, highlight the results, then use the copy (Ctrl-c) keys and the paste (Ctrl-v) keys.  If your "IP address"  does not start with 192.168  , then for security reasons, erase the last half of your IP address from your post.

scrooge
Posts: 2,610
Registered: ‎09-07-2006

Re: When I hook up router through modem, no internet, modem only internet ok

Your router is not configured, you need to configure your router...

 

As your Internet Service providor is DSL follow this link

Huggy Bear
Posts: 1
Registered: ‎06-23-2010

Re: When I hook up router through modem, no internet, modem only internet ok

Hi ,

Know this is an old post- still applies to my befw11s4 wireless router.  Have had it working before.

 

Internet works when direct from cable modem to computer. Once I introduce router into equation the no go.

Tried all the shutdown,reboot  and configure info I could.

 

IPConfig info is:

 

connection specific DNS suffix is blank

IPAddress is 192.168.1.100

Subnet Mask 255.255.255.0

Default Gateway  199.168.1.1

 

Any thoughts?  Thanks,   Huggy Bear