Reply
RustInPieces
Posts: 6
Registered: ‎02-22-2010

Re: Xbox 360 NAT issues solved!!! (WRT160N v3)

http://imgur.com/1GtmV.jpg
ryan.c.stillman
Posts: 1
Registered: ‎02-25-2010

Re: Still having issues

I have made my router configuration just like the picture.  I also gave my Xbox the IP adress as well.  Still I'm having problems with getting a Moderate NAT Setting.  The uPNP is enabled.  What do i do now?
Quadjunky
Posts: 1
Registered: ‎02-25-2010

Re: Still having issues

[ Edited ]

If you want to have trouble free gaming on the wrt160 with 2 xbox 360's enable uPNP and disable the SPI firewall and any port forwarding you have done.  Its the only way me and the wife can play the same game online like gears 2 etc...

 

If I enable SPI firewall which ever xbox signs on first get open nat the other will get moderate or strict.....

With it disabled we have no problem hosting a game on each xbox at the same time.....

 

After many hours of beating my head against the wall and almost going back to my old wired befsr41 this fixed the problem.....

 

Running stock firmware btw....

 

Hope this helps you out...

 

 

Message Edited by Quadjunky on 02-25-2010 06:52 PM
Brown Eye 02
Posts: 6
Registered: ‎02-25-2010

Re: Still having issues

[ Edited ]

Ok I have a wrt320n I just want to make that clear. The way I got open NAT was by disableing Upnp, and all my port fowarding's and enabled DMZ using my mac address. This right away gave my open NAT but the problem was yes my xbox had open NAT but now my computer has moderate so I would have trouble with GTA4. So the only way I was able to get them both with open NAT was by connecting my xbox to my computer with a cat5 cable and having my computer connect to my router. And setting my routers DMZ  to my computers mac address.

I read an article that said if your going to foward ports disable DMZ and Upnp/ If your going to enable Upnp disable DMZ and port fowarding/ If your going to enable DMZ disable port fowarding and Upnp. He said dont have more then one enabled. My problem is I know opening your ports is very dangerous because it makes you easly hackable. Is there any other know way to get open NAT with out compramising your hackibality. And post if this helps anyone!!!!

Oh and Quadjunky  disableing the SPI firewall didn't work for me but again that was for a wrt160 so that may be why.

Message Edited by Brown Eye 02 on 02-25-2010 09:06 PM
Expert
Expert
Posts: 12,649
Registered: ‎07-16-2006

Re: Still having issues

My problem is I know opening your ports is very dangerous because it makes you easly hackable. Is there any other know way to get open NAT with out compramising your hackibality.


That's impossible. When you have "open nat" it means all ports are correctly forwarded and open. It does not matter how those ports are opened (port forwarding, DMZ host, UPnP forwarding). If you want to lower your risk, don't forward ports and accept whatever NAT level you get without forwarding. Either you want "open nat" and open ports or you don't want "open nat".
Brown Eye 02
Posts: 6
Registered: ‎02-25-2010

Re: Still having issues

All right I just wanted to make sure. Thanks
TsK215
Posts: 6
Registered: ‎02-26-2010

Re: Xbox 360 NAT issues solved!!! (WRT160N v3)

I too am having this issue with my WRT160N.  I have been trying for weeks to find the proper configuration for my 2 Xbox 360's.  The first console turned on gets "open" NAT and the second turned on gets "strict" NAT. 

 

I have spend hours searching the web for a configuration that works.  I have tried every configuration for port forwarding, port triggering and DMZ and the best I can do is get both consoles to obtain "moderate" status.  I have tried every configuration posted on this thread and still cannot get "open" status on both consoles.

 

I am tempted to go back to my old Linksys BEFW11S4 router as I could get "open" status on both Xboxs, however my wireless speeds were at a crawl.

 

Linksys/Cisco, please give us a firmware update that will allow us to play on Xbox Live with multiple 360's obtaining "open" status!!!

Brown Eye 02
Posts: 6
Registered: ‎02-25-2010

Re: Xbox 360 NAT issues solved!!! (WRT160N v3)

I agree it would be nice to have all routers support open nat on xbox live. For now just like my post said you can only have open nat for 1 system using DMZ unless port fowarding works for you or Upnp. But DMZ will only alow 1 system to have open nat if its your fix. It seams the fix is different for everyone. Some can get open NAT by enableing Upnp, others using DMZ like me, others fowarding some ports. WHY!!!!!! I cant wait till we have a drop down columb which says open NAT moderate NAT and strict NAT for a setting.
TsK215
Posts: 6
Registered: ‎02-26-2010

Re: Xbox 360 NAT issues solved!!! (WRT160N v3)

Ok, after weeks of changing my configurations, the best one I have come up with for 2 Xbox 360's on a Linksys WRT160N is as follows (this will give you "open" NAT status on your primary 360 and "moderate" status on your secondary 360):

 

First, I looked up both MAC addresses for the 360's.  You can do this by opening the dashboard in the Xbox 360 and going to the MY XBOX tab.  Scroll all the way to the right and go into the System Settings tab.  Choose Network Settings and then Configure Network.  Choose additional settings by pressing right on the thumbstick and then go down to Advanced Settings and press A.  On the bottom left will be your wired MAC address.  Write this down for both Xbox 360's.

 

Log into your router.  In the setup tab when you first log in, you should find a DHCP reservation button next to your DHCP server settings.  Click the DHCP reservation button and in the manually adding client box, type Xbox 1 under Client Name.  Then under Assign IP Address, type in an IP that you want the first Xbox to use (such as 192.168.1.110).  Then in the "To This MAC Address" box, type in the MAC address for the primary Xbox 360.  Click the ADD button.  Repeat this procedure for the Xbox 2 using a different IP address (such as 192.168.1.111).  Click the SAVE SETTINGS button and then close this window.  This will ensure that both Xbox 360's are using the same IP address each time they are turned on.

 

Next go into your Applications and Gaming tab at the top of the screen.  Clear any previous settings that you have configured under each tab.  You should have nothing enabled under Single Port Forwarding, nothing under Port Range Forwarding and nothing under Port Range Triggering.  Go into your DMZ tab and click the Enable radio button.  Under Source IP address you should have the Any IP Address option chosen.  Under Destination, you should have the IP Address button chosen and next to it, you should have the IP address of the primary Xbox (in this example it would be 192.168.1.110).  This is the Xbox 360 that will always recieve "OPEN" NAT status.  Click the SAVE SETTINGS button.

 

Next go  to the Administration tab.  Under UPnP, click the DISABLE button.  I know everything you have probably read tells you to be certain that UPnP is enabled, but trust me.  Click the SAVE SETTINGS button.

 

Power off your modem, router, both Xbox 360's and your computer (and any other device on the network).  Wait at least 30 seconds.  Turn on your modem and allow it to boot up completely.  Then power on your router and wait for all the lights to stop flashing as to be certain it has completed booting up.  Then power on your computer and Xbox's.  You should receive "open" status on the primary Xbox 360 and "moderate" on the secondary 360.  Using this set up, you should be able to party up with each other and play together on the two Xbox's.  This is the best configuration that I have found so far and my kids will just have to deal with having "moderate" status.

 

Let me know if anyone else has any success with this configuration.

Supertech100
Posts: 1
Registered: ‎02-27-2010

Re: Xbox 360 NAT issues solved!!! (WRT160N v3)

Thanks...this worked with my Linksys WRT160N router finally. You must go to "ADMINISTRATION", then "MANAGEMENT" and disable the "UPNP" for it to work.   Afterwards you need to go to "Applications & Gaming", then "Port Range Forwarding" and open ports:

88 (choose "BOTH" for protocol)

3074 (choose "BOTH" for protocol)

53 (choose "BOTH" for protocol)

80 (choose "TCP" only protocol)

 

 If you need more details on how to enter the ports let me know.