Showing results for 
Search instead for 
Do you mean 
Reply
DowzaMP
Posts: 1
Registered: ‎12-23-2010

"Bricked" WRT310n V1

During a firmware upgrade I seem to have "bricked" by router.

 

Have tried to TFTP new firmware to the device and all seems to go OK i.e. I boot th WRT and TFTP starts and finishes correctly after uploading the firmware but the blue power light keeps flashing and I can't access the web managment - the WRT can be pinged at its address 192.168.1.1 after I have uploaded the firmware up until I power cycle it and then it can't be pinged until I start the firmware flash process again

 

Have I missed anything?

SpudNuts
Posts: 27
Registered: ‎11-16-2010

Re: "Bricked" WRT310n V1

I actually had the same issue but mine was because I installed the V2 firmware on a V1 and bricked mine.

 

I had a really hard time getting the original firmware installed but here are the steps that finally worked.

 

Downloaded the firmware to my laptop and put on the root of C:\

renamed the file to upgrade.bin (just to make it easier to type)

I connected my laptop to port 1 and put my laptop into the network with an IP of 192.168.1.100, subnet mask 255.255.255.0 and gateway 192.168.1.1

I opened 2 command prompt windows.

On the left side of the screen I ran a continuous ping (ping -t 192.168.1.1)

On the right side of the screen I setup a tftp (tftp -i 192.168.1.1 PUT upgrade.bin) at the root (type c:\ and enter to get to root) but don't hit enter yet.

I then plugged in my router, press the reset and hold it. Hold it until you see the ethernet port light turn off, it will be off for like a second or two. This will take somewhere around 45 seconds to a minute. Once I see the ethernet port go out, I let go of the reset and pressed enter on the tftp.

 

About 10 seconds later I saw the pings were successful and then a bit later I would see the transfer succeed.

 

Then I reset the router again, but this time just for 30 seconds.

 

Once that was done, my router was restored completely.

 

Hope it works for you.

CnM99
Posts: 1
Registered: ‎07-01-2011

Re: "Bricked" WRT310n V1

I have the same problem. Loaded the wrong version firmware. I don't understand all the steps you did to fix your router. how do you do all the ip settings and things? Thanks.

 

Chuck

 

Expert
sabretooth
Posts: 5,312
Registered: ‎11-11-2008
bpw1111
Posts: 1
Registered: ‎07-30-2013

Re: "Bricked" WRT310n V1

[ Edited ]

Hello SpudNuts: I just wanted to say Thank-You !. Your procedure saved my router, and saved me some money. I appreciate you posting how you did it.

Sincerely; Brian W.