Reply
Posts: 7
Registered: ‎09-26-2017

LAPAC2600 - iOS connectivity issues

Hello everyone,

 

we are using some LAPAC2600 in a clustered mode, using the latest firmware. These APs offer a SSID named "corporate", which is a WPA2 PSK. So to say, a simple setup. This SSID is configured on many devices, including smartphones, notebooks, etc. The WiFi signal strength has been tested across that location, it ranges between 32 and 55 dBm. This is sufficient.

 

Since some time, we are experiencing issues especially with iOS devices (10.2, 10.3, 11.0). There's a rough guess that this behavior has occurred more often since the APs were updated to V1.0.03.000.

 

Scenario 1:

User enters the location and goes to his desk. He looks on his locked iOS device, no WiFi connection. He unlocks the device, the device connects to the WiFi.


Scenario 2:

User enters the location and goes to his desk. He looks on his locked iOS device, no WiFi connection. He unlocks the device, still no WiFi connection. He opens Settings > WiFi, the SSIDs are being listed and the device automatically connects to the WiFi.

 

Scenario 3:

User enters the location and goes to his desk. He looks on his locked iOS device, no WiFi connection. He unlocks the device, still no WiFi connection. He opens Settings > WiFi, the SSIDs are being listed and nothing happens. He manually taps the WiFi "corporate" once, and the device is connected.

 

Actually we have no clue what's causing this behavior. For instance Windows devices do not have any issue with this SSID. It seems to be a combination of iOS devices and the LAPAC. Does anyone have a suggestion or idea what could be causing this?

 

Kindest regards,

M

Expert
Posts: 13,604
Registered: ‎01-18-2013

Re: LAPAC2600 - iOS connectivity issues

Below is a post I found on the Apple Forums regarding this:

 

 

 

1) go to Settings->General->Reset->"Reset Network Settings". This will force a reboot of the phone & erase all of the networks previously stored.

2) when the phone comes back on, go to Settings->Wi-Fi-> set "ask to join networks" to "on".

3) join the network, and input password.

4) after successfully connecting, leave the Wi-Fi network coverage area once, and come back into it. It should connect automatically again

5) go back into Settings->Wi-Fi-> set "ask to join networks" to "off"

 

 


Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Posts: 7
Registered: ‎09-26-2017

Re: LAPAC2600 - iOS connectivity issues

Hi chadster,

 

we did try the following mitigations on affected devices:

 

  • Reset Network Settings
  • Reinstall Device via DFU mode
    • Test without restore from backup
    • Test with restore from backup
  • Deactivate WiFi Assist
  • Reinstall MDM profile (the WiFi configuration is deployed via MDM)

Sadly none of these has solved the issue. The same devices are working fine in other Wifis (AirPort, Fritzbox, Meraki), leading to the conclusion that this behavior is at least somehow related to the Linksys LAPAC2600 APs.

 

Kindest regards,

M

Expert
Posts: 13,604
Registered: ‎01-18-2013

Re: LAPAC2600 - iOS connectivity issues


MMustermann wrote:

 

same devices are working fine in other Wifis (AirPort, Fritzbox, Meraki)


Did you have the iOS devices roaming across these other plaforms? (Going from AP to AP)


Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Posts: 7
Registered: ‎09-26-2017

Re: LAPAC2600 - iOS connectivity issues

Hi chadster,

 

the other WiFis are without roaming across multiple APs and located some kilometers away. The WiFi connection is being established automatically, once in range. When coming to the LAPAC2600's APs, at first there usually is only one single AP in range. So prior to roaming, the device should connect to this firstly discovered AP and that is, what does not happen. Even when crossing the overlapping AP ranges, so a new AP/beacon could be discovered, the device does not join.

 

Kindest regards,

M

AE
Posts: 4
Registered: ‎10-17-2017

Re: LAPAC2600 - iOS connectivity issues

[ Edited ]

@MMustermann  -  Did you find a solution to this problem?

 

 

I have 5 of the LAPAC2600 APs setup in clustermode with 802.11k enabled on all APs broadcasting only 2.4GHz on a single antenna. Roaming between APs when using an iOS device just simply does not work!

 

I tested with an Android device and Windows Surface device and roaming appeared to work properly, but iPhones and iPads just won't auto reconnect to another AP that is closer when moving about the area. All iOS devices are up to date and I have reset the network settings on each device, but no luck!

 

I have the latest firmware installed on all APs. I have even changed the Power to AUTO to help reduce overlapping congestion, but no difference. There just seems to be a compatability issue with the LAPAC2600 and iOS devices.

 

Anyone else have this problem?

 

Anyone at Linksys support care to provide some feedback?

Expert
Posts: 13,604
Registered: ‎01-18-2013

Re: LAPAC2600 - iOS connectivity issues


AE wrote:

@MMustermann  -  Did you find a solution to this problem?

 

 

I have 5 of the LAPAC2600 APs setup in clustermode with 802.11k enabled on all APs broadcasting only 2.4GHz on a single antenna. Roaming between APs when using an iOS device just simply does not work!

 

I tested with an Android device and Windows Surface device and roaming appeared to work properly, but iPhones and iPads just won't auto reconnect to another AP that is closer when moving about the area. All iOS devices are up to date and I have reset the network settings on each device, but no luck!

 

I have the latest firmware installed on all APs. I have even changed the Power to AUTO to help reduce overlapping congestion, but no difference. There just seems to be a compatability issue with the LAPAC2600 and iOS devices.

 

Anyone else have this problem?

 

Anyone at Linksys support care to provide some feedback?


Thanks for adding your report to this thread.


Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Expert
Posts: 13,604
Registered: ‎01-18-2013

Re: LAPAC2600 - iOS connectivity issues

I have notified Linksys engineering of this iOS roaming and auto connect issue referencing this forum thread.


Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
AE
Posts: 4
Registered: ‎10-17-2017

Re: LAPAC2600 - iOS connectivity issues

Thanks Chadster766!

Hopefully they come up with a quick fix and release a firmware update that resolves the problem. Until then, I think I will have to use a different AP since I need to resolve this issue asap.
Posts: 7
Registered: ‎01-22-2018

Re: LAPAC2600 - iOS connectivity issues

I too have this issue. Multiple LAPAC 2600, and I am on firmware V1.0.04.001 on all APs. I have experienced the same problems as the original poster mentioned in the first post. I too am operating them in cluster mode, and have a single SSID for both bands.