Reply
Posts: 14
Registered: ‎04-19-2017

One Linksys Router + Velop -> One WiFi Mesh!?

Hi Linksys dev. team,
I have an EA9500 and the three nodes Velop (WHW0303). I am forced to close the Wi-Fi on the router and have the Velop in bridge mode just to keep my house almost fully covered by good Wi-Fi. My home office which is in the basement gets 10% - 20% Wi-Fi compared to other parts of the house (very old house - thick walls)
Suggestion:
Add the Velop's functionality (add nodes) to the router and create the possibility of having a Wi-Fi mesh composed of 1 router + the Velop nodes.

Example:

Setup the EA9500's Wi-Fi and have a button on the app to "create Wi-Fi Mesh" by adding the Velop's nodes one by one ... just like with the Velop app.

This way we would skip the challenges with the "Bridge Mode" (where we lose some of the key points that makes the Velop such a good system.

Think of it :-) ... EA9500 is probably the best router on the market today (8 Gigs ports, two USBs, triband, 8 antennas great coverage and so many more) ... add to this that the Velop beats everything on the market ... and we would get the best out of two very good systems without losing any their good features.
Call this Linksys Mesh option or "Linksys allows its users to create Wi-Fi mesh using proprietary systems".
Looking foward for a roadmap where this feature is added.
All-the-best :-)
 

Highlighted
Posts: 10
Registered: ‎07-17-2017

Re: One Linksys Router + Velop -> One WiFi Mesh!?

I was thinking of this too before I took back an EA9500 I was comparing against the Velops.

 

The other big annoyance/drawback with the EA9500 was that the Guest Network on the EA9500 functioned differently (it had the captive portal instead of just being another WPA2 password protected network like the Primary).

 

I also didn't like losing the extra abilities on the Velops either.

 

On a side note, after a couple of weeks on just a pure Velop system here at my house, and being on the beta firmware provided by Linksys/chadster, I'm still noticing crazy latency/ping spikes which are offputting, so I'm currently thinking about trying out the Velop bridge mode again (and putting back in place my previous router to hopefully improve/reduce that latency I mentioned). As an example, I just upgraded my internet, and here in my office area (which has my desktop connected via ethernet to Node 2) running internet speed tests I'm only getting about 120 Mbps or so max in several rounds of tests and I just ran the speedtest on a device wired directly to the primary Velop node and it was able to get 298 Mbps down so there's definitely a big dropoff occurring and these nodes aren't even that far away from each other.