Reply
Posts: 6
Registered: ‎12-24-2017

Getting less than half the speed vs. my Airport Extreme

Ugh. This is frustrating. I connected Node 1 directly to my U-verse Modem. For testing, I left my AirPort Extreme connected to the modem as well. I added a Node 2. Now - I’m sitting in a chair about 10 feet from Node 2 and 30 feet from Node 1. Velop SSID is delivering 85 Mbps down/ 20 up to my iPhone. Without moving, i switch to my AirPort Extreme SSID and am getting 203 Mbps down/ 143 up.

That’s not acceptable. What could be happening? I currently only have 1 device (my iPhone) accessing the Velop SSID.
Posts: 39
Registered: ‎11-22-2017

Re: Getting less than half the speed vs. my Airport Extreme

Junk.

Take it back while you can.
Posts: 36
Registered: ‎08-18-2017

Re: Getting less than half the speed vs. my Airport Extreme

Agree. Return it while you can! 

Posts: 6
Registered: ‎12-24-2017

Re: Getting less than half the speed vs. my Airport Extreme

Okay - thanks guys.  After testing with a few different devices in different locations, I verified that my speed through the Velop was way underperforming my AirPort consistently.

 

I've packed it up and got my RMA from Amazon...so it's going back today.

 

Thanks.

Posts: 63
Registered: ‎08-27-2017

Re: Getting less than half the speed vs. my Airport Extreme

I would be interested in knowing which version of FW you are running?

 

Lator

Posts: 39
Registered: ‎11-22-2017

Re: Getting less than half the speed vs. my Airport Extreme

No one should have to play the firmware game to get the velop to work. At the price point velop is they should work right out of the box.

Linksys doesn’t want to fix the issue we should vote with out money. I would return mine if I could.
Posts: 6
Registered: ‎12-24-2017

Re: Getting less than half the speed vs. my Airport Extreme

Not sure about FW. But after I set it all up it forced a firmware update.

I agree with the above. If it installs correctly and verifies correct firmware then it should work as advertised. It didn’t.
Posts: 36
Registered: ‎08-18-2017

Re: Getting less than half the speed vs. my Airport Extreme

Agree with all! We have community college drop out support on these forums (tier1) and I am guessing their Dev/FW team is even worse.  Sad to think this is the type of support they throw at a product at this price point.

Posts: 63
Registered: ‎08-27-2017

Re: Getting less than half the speed vs. my Airport Extreme

I don't disagree with you all on the FW issue.  I've been battling FW problems since Apr/May of this year.  That said, If you can return them, do so; I can't at this point.  I just read an article about the EERO second gen; very positive and works perfectly out of the box.

 

For those who are stuck with what they think are ugly paper weights, changing FW might do the trick for you. 

 

Lator

Posts: 6
Registered: ‎12-24-2017

Re: Getting less than half the speed vs. my Airport Extreme

Good point. I did just order an EERO 2nd gen to try next. We will see how that does soon.