Posts: 2
Registered: ‎06-19-2017

Nodes will not connect to the main node

My new Velop system has so far been a massive hassle to set up.

The first node is easily set up. Connects immediately to the Internet and creates a great wireless network in minutes.

However, when I add more nodes the installation program(iOS gets stuck on the step ´Checking node location´.
This is after the app has found the node, after it has completed connecting to the Velop system and downloaded settings.

I am a semi-patient man but after waiting for fifteen minutes for each of my two extra nodes trying to find a location, I gave up. I did after all, know where I was at the time.

Someone here had the bright idea to update firmware so I reset the nodes and installed each of them as new ´main´ nodes, SSIDs and everything.
Finally, I had three nodes on firmware 1.1.1180735 but no more beer.

I got more beer.

Feeling optimistic, I tried resetting two of the nodes and kept the node with the wittiest SSID as the main. Then I tried adding the nodes again but alas, I get the same annoying condition where the app is showing me the pulsing bars for 20 minutes while I am looking at it like the hypnotized squirrel from Ice Age.

Does anyone have a solution to this? And please, do not make me reinstall them as mains again. I can´t come up with more SSIDs.
Posts: 0

Re: Nodes will not connect to the main node

Hi there, DeanDropshot,


Thanks for the detailed insight. Try out these steps:

  • Reset all the nodes before setting it up.
  • Uninstall and reinstall the Linksys Smart Wi-Fi app.
  • Relocate the nodes.

Should you experience the same ordeal, please shoot us an email at so we can have our Escalation Engineers lend you a hand with the Velop nodes.

Posts: 5
Registered: ‎06-22-2017

Re: Nodes will not connect to the main node

I am having the same issue as DeanDropshot - will try the suggested solution

Posts: 2
Registered: ‎06-19-2017

Re: Nodes will not connect to the main node

This kind of solved the problem for me.


* Installed all nodes as main nodes and updated the firmware.

* Reset all nodes.

* Set up main-node and added a sub-node.


My second sub-node still failed to set up. It just stalled on the 'Testing location' part.

Frustrated, I passive-agressively hid the node behind a book and left it alone.

When I passed it the next day I noticed it was displaying the solid blue LED. Turns out it had connected sucessfully to the rest of the network and given itself a generic LinkSys-name.


So in my case I have all three nodes working happily together now. I don't quite know how it happened, but it did.



Posts: 1
Registered: ‎06-24-2017

Re: Nodes will not connect to the main node

Set up a 3 unit system today. 


Main unit connected quickly. Firmware showed up-to-date and set to automatic.

Node 1 hung trying to connect.  Reset it and walked away.  after a while, it spontaeously connected.

Node 2 failed sometime after connecting and location steps.


Velop Tech support 800.986.0518 answered after 1/2 hr.

She was very knowledgable and helpful.


Now Linksys Smart Wifi PC app showed a firmware update was available.

Updated firmware on main unit.

Then reset and updated firmware on Node 1.

Reset and reconnected Node 2. Then updated firmware.


All three nodes are working now.


Posts: 1
Registered: ‎11-24-2017

Re: Nodes will not connect to the main node

Honestly the most frustrating system in the world. The apps UX is appalling constantly logging you out instead of letting you go back.

I set up a node but then the other 2 nodes could not be found. I then spent 2.5 hours on the phone to tech support who could not solve this and I ended up with 2 routers, a useless node in a draw and 4 ghost Wifi networks which my devices keep connecting to.

Having lost my patience and run out of vodka I decided I would call tech support back to try and solve having 2 routers in an apt 1200 sq feet which makes no sense. 2 hours later and 3 support people later I have exactly the same problem.

An expensive waste of my time that something that should be so simple.

Even setting up an account here to comment is not linked to the linksys app so now I have 2 linksys accounts!

Simple amazing!
Posts: 1
Registered: ‎12-20-2017

Re: Nodes will not connect to the main node

It;s drib=ving me nuts. I had a 2 node systej for ages and it is great. Third node even though it joins the suystem fails wehn trying to establish the location.


This is really really sh*t guys and eating uo half my bloody life.

Posts: 252
Registered: ‎08-22-2017

Re: Nodes will not connect to the main node

Hi, Everyone! Please email us at along with your contact details, community username, and the link to this community thread for reference and we can have our Escalation Engineers assist you further on this matter. Thanks.

Carl_S 21985
Linksys Technical Support
Posts: 1
Registered: ‎01-03-2018

Re: Nodes will not connect to the main node

I will email the link above, but purchased new Velop system ...3 pack. App went well, directions followed, and all went well until app found first node, then only message in app was “setting up for remote access” never got past that after several tries and resets After 40 mins on hold with Velop tech support, I gave up. I am not very tech/pc savvy, which is why I was going with something “easy to set-up” but don’t have patience for reboots and resets. Hope someone can figure it out for me.
Posts: 3
Registered: ‎09-27-2014

Re: Nodes will not connect to the main node

[ Edited ]

I had the same problem.  My suspicion is that it's caused by having different firmware versions on each of the nodes. 


When I installed the first node, I chose not to add the additional node at the same time.  The setup app duly proceeded to check for new firmware and upgraded to the latest version.  When I went to add the second node, it just timed out on the 'checking location' stage.


The solution which worked for me was broadly similar to what others on this thread have been suggesting:


1) set up node 1 using the linksys app

2) do not add any additional nodes at this point (select "not right now")

3) upgrade the node 1 firmware when prompted

4) wait for the update process to complete and for node 1 to successfull reboot (solid blue light)

5) unplug node 1 and switch off (it's not necessary to reset this node)

6) plug in the second node and set it up as if it were the first

7) again, do not add any additional nodes at this point

8) upgrade the firmware on node 2 when prompted 

9) wait for the update process to complete and for node 2 to sucessfully reboot (solid blue light)

10) reset node 2 per Linksys instructions (i.e. hold down reset button for 10 seconds until the red light disapears)

11) plug node 1 back in and power up

12) once node 1 is ready (solid blue light) power up node 2

13) make sure your phone is connected to the node 1 wifi

14) open the linksys app and login

15) Use the 'add a node' option in the main menu and add node 2 to your network

16) Follow the in-app instructions and you should be good to go.


After much faffing, this worked for me.  It's pretty sloppy of Linksys to allow such an obvious problem to arise in set-up, so hopefully the get on the problem for future app/firmware releases.