Reply
Posts: 8
Registered: ‎01-18-2018

Re: Slow Ethernet Connection

Firmware support for these routers has been horrible. They stepped it up with the mobile app but the firmware releases has been slow. I should of just got another Eero set instead.
Moderator
Posts: 151
Registered: ‎08-08-2017

Re: Slow Ethernet Connection

We'll check on this, Embers. Have you tried using a different browser to check if the same error happens? You can also try using a different ethernet cable or plug it on another laptop or PC so we can isolate the issue. Also, is your slave node running on the latest firmware?

Jo-Ann - 21744
Linksys Technical Support
Posts: 8
Registered: ‎01-18-2018

Re: Slow Ethernet Connection

There isn't an error, it just takes a few minutes before it connects. This occurs when using my Macbook, PC, Xbox, Raspberry Pi, and Samsung DeX. It takes a few minutes before these devices connect when using ethernet. All of these devices connect right away when using Wi-Fi. This occurs when plugging any device via ethernet. Which ever fixes were in firmware 1.1.2.184933 resolved it. Since there were issue with that firmware the latest firmware only includes krack/vulnerability fixes. Both nodes are using the latest firmware.
Moderator
Posts: 176
Registered: ‎08-22-2017

Re: Slow Ethernet Connection

[ Edited ]

@WannaBeOCer wrote:
There isn't an error, it just takes a few minutes before it connects. This occurs when using my Macbook, PC, Xbox, Raspberry Pi, and Samsung DeX. It takes a few minutes before these devices connect when using ethernet. All of these devices connect right away when using Wi-Fi. This occurs when plugging any device via ethernet. Which ever fixes were in firmware 1.1.2.184933 resolved it. Since there were issue with that firmware the latest firmware only includes krack/vulnerability fixes. Both nodes are using the latest firmware.


Got that, WannaBeOCer. It seems a bit odd for the devices to take time to connect. How far is the router, though? Just to clarify, do you mean this happens only on the wired connection? If so, I recommend you to try another ethernet cable and see how it goes. 

Nestor_C 21974
Linksys Technical Support
Highlighted
Posts: 8
Registered: ‎01-18-2018

Re: Slow Ethernet Connection

[ Edited ]

Yes when using wired connection. I tried every possible solution. Only solution that worked was plugging the modem in directly or using a router that wasn't a Velop. What ever firmware fixes were in 1.1.2.184933 fixed it. It's a firmware issue and needs to be fixed.

Posts: 8
Registered: ‎01-18-2018

Re: Slow Ethernet Connection

[ Edited ]

Just wanted to give an update, I sent Belkin a tasteful email early in March and the firmware Ver. 1.1.2.187020 fixed the ethernet issues just like 1.1.2.184933. Shocked how long it took for them to fix the issue.

Posts: 2
Registered: ‎03-03-2018

Re: Slow Ethernet Connection

[ Edited ]

Excellent I will test out tonight.

 

Just for the record I did try a different ethernet cable and there was no difference. Browser also has no difference as its a delay in PC nic registering / getting IP from Velop node.