Posts: 4
Registered: ‎10-14-2008

Cannot Associate With Access Point

WRT54GX4 router; 2 Dell laptops and 1 Dell desktop connected happily for over a year (laptops using Wireless-G SRX400 cards and desktop using Wireless-G USB adapter with RangeBooster).  All PC's on XP Pro SP3.


Router on Channel 1, broadcasts SSID and uses WPA-Personal w/AES (this setup has worked for over a year and still is working for 2 laptops)

Desktop stopped connecting 5 days ago (no programs installed or upgraded in previous 3 weeks); got error message in subject line. Can find wireless SSID in both Linksys Monitor and XP Wireless Config, but cannot associate with it.


Tried to troubleshoot with logic, experience, and via Internet; problem seems prevalent with Linksys adapters but cannot find a fix.


Bought new adapter -- WUSB54GC; uninstalled old software and adapter and installed new.  No soap, still getting error message.  

Have reset AP numerous times.  Have deep scanned computer multiple times - no spyware, viruses, etc.  Have tried different USB ports; no soap.  All other programs running hot straight and normal; just cannot get onto Internet.


Would rather stick with Linksys but about at end of rope and ready to try NetGear, Belkin, etc.


Any and all ideas and suggestions gratefully welcomed.  Many thanks!


David Ives


Posts: 3,809
Registered: ‎09-07-2006

Re: Cannot Associate With Access Point

Click on the Start button >>> Control Panel >>> Network Connections-
Here right click on the "Wireless Network Connection" icon and select
Properties- Click on the 'Wireless Network' tab- Remove all the names from the list.

Click on the 'Add' button below- Provide the network name in the SSID box exactly as set on the router/gateway(as it is case sensitive)- Data encryption (WEP enabled) should be checked- Uncheck the box that says, "The key is
provided for me automatically"- Type the network key in the Network
key box as set on the router/gateway and then confirm it again and
click Ok.

Posts: 4
Registered: ‎10-14-2008

Re: Cannot Associate With Access Point

Thanks, but I have tried that with no luck.  Also tried reducing the beacon interval to 50 and reducing the RTS and fragmentation by 40.  Also uninstalled the adapter sw, inserted the adapter disk, exited from the Linksys setup , unplugged and plugged the adapter back in and let Windows install the New Hardware.  Also made sure that all of the wireless AP and DSL modem settings were correct (they were).  This seems to be a widespread problem with Linksys hardware.  Tomnorrow I'm buying a D-Link/NetGear/Belkin wireless adapter and trying that.  Thanks for the suggestion though.



Posts: 4
Registered: ‎10-14-2008

Re: Cannot Associate With Access Point -- THE FIX

Tried a Belkin and a NetGear wireless adapter; no go.

If only one out of 3 computers is having this problem, the source of the problem should NOT be the Linksys WAP (WRT54GX4).  But it turns out that indeed it was the source of the error.  I reset it (via the "hole in the back" reset).  Plugged an Ethernet cable into one of my laptops and connected it to the WAP.  Browsed to the 192.168... WAP address and set up my wireless network from scratch.  All 3 computers immediately connected and the "cannot associate..." problem went away.  Didn't change ANY of the WAP setup information; just flushed it via a reset and re-entered it anew.



Posts: 1
Registered: ‎10-22-2008

Re: Cannot Associate With Access Point


Have you had any success resolving this? I have a similar problem. Have 2 Dell problem with access point. Have a Dell pc with wireless adapter that has worked for 2 years and quit the 1st week of October. Had some success doing a Restore to previous date. It will associate with access point, connect with the internet. Windows then wants to update (detecting the old restore point), when windows completes the update and restarts the connection has a problem again.

Posts: 4
Registered: ‎10-14-2008

Re: Cannot Associate With Access Point

I fixed the problem by directly connecting a laptop to the Linksys wireless access point; then resetting the WAP (returning it to its factory defaults).  I then connected to the WAP and set it up as if it was a "brand new, out of the box) access point.

Doing this has eliminated the "cannot associate with access point" problem on my network.



Posts: 2
Registered: ‎11-30-2015

Re: Cannot Associate With Access Point

This would likely happen if there's security set upon the connection and you have not typed or incorrectly typed that code during the connection.

Plug back into the device (whatever's doing the wireless) via Ethernet and check the configuration carefully.

If there are settings for a "WEP key" or similar on the security page, then you'll need to make a note of what's in there and type it in when the connection asks for it.

You could also disable the security for the access point, but then any goober who wanders by can connect to it and start poking at your computer(s), so that's not the best solution.