Reply
Posts: 5
Registered: ‎10-19-2017

Re: EA7300 loses internet connection but only on wifi

I spent a long time tweaking every setting I could find and asking for help here. At times I've managed to go 24 hours without the issue, but it always comes back. It seems to be a problem inherent with the router. I've given up on it and ordered a different one yesterday. This one is just a dud.

Highlighted
Posts: 5
Registered: ‎11-29-2017

Re: EA7300 loses internet connection but only on wifi

That's what I'm afraid of, looks like I wasted $120 on it.  I was hoping Linksys would hear everyone complaining about it and do something, but they've been silent on the issues except to suggest moving to a different channel or factory resetting the router yet again.  I'll probably give it a little more time to see if they come out with a firmware update that fixes it, but I'm guessing I will end up having to get something different.

Posts: 3
Registered: ‎12-02-2017

Re: EA7300 loses internet connection but only on wifi

I had this problem with my old linksys router. Got rid of my EA3500 because it updated to the latest firmware and then this problem began.  I bought the EA7300 and as soon as I selected to update firmware to this version, the problems transferred to the new router.  I cannot seem to keep any device online not even for 10 mins.  

Posts: 4
Registered: ‎12-06-2017

Re: EA7300 loses internet connection but only on wifi

My router EA7300 have the same symptoms.

 

I changed my previous one, Cisco Valet, because signal degradation. I plug my cable modem and router in a UPS, after week or more without power cycle I noticed that my devices got slow connection and sometimes can't connect via wifi, I decided to buy a new one, with mi-mo and more robust to handle all my videogame systems, mobiles and notebooks/tablets.

 

EA 7300 was the best choice for the price. But I notice for a long time now, that my wifi network was different, hanging to load pages, my online games running poorly and when I got a chance I started to document all my tests, and notice packet loss inside my network, change my USB WiFi adapters ( AE6000 ) and notice that when I reboot the router becomes better, I don't know if the router can handle with all the devices, got some degradation in the service with time without a power cycle or the firmware changed something.

 

I am a brand loyalist but Linksys from some time is dropping the ball. Since my WRT54G I keep loyal to the brand but it's testing my patience.

 

if until the end of the year, nothing changes, maybe with the christmas deals I will get a new router and see what is available.

 

Let's wait and see.

Posts: 5
Registered: ‎10-19-2017

Re: EA7300 loses internet connection but only on wifi

I'd have some success after rebooting the router but it would never last more than a few hours. I've had a different router for nearly a week and all the problems I was having with the EA7300 have disappeared.
Posts: 2
Registered: ‎11-02-2017

Re: EA7300 loses internet connection but only on wifi

Largley crickets from the Linksys team. I was hopeful for someone from the Linksys tech support team to respond to the thread stating that they're working on new firmware for the router, but the only response I've seen is to perform rudimentary configuration changes that everyone in this thread likely had already tried prior to posting their issue. I guess this is very telling of what Linksys has become, which is a shame. I purchased this router expecting good results since that's what I've been accustomed to in the past with other Linksys equipment, but it looks like I'll just end up buying another brand router from here on out. Perhaps Linksys can take ownership of the issue and fix the faulty product they've sold us, but I'm affraid at this point even if they do it'll be too late.

Posts: 3
Registered: ‎12-02-2017

Re: EA7300 loses internet connection but only on wifi

Today I am working under an Apple Air Express Router to make sure is not the Xfinity line like they said.  Is been more than 24hrs and no drops at all. 

 

I have reset the EA7300 back to default settings and reset another WiFi to test and sure enough kept dropping.  Is definitely something with this firmware version that is not working right.  

 

I just hope Linksys comes up with a fix for this because the Air Express is not giving me the signal strength that the Linksys gives.  

Posts: 2
Registered: ‎12-13-2017

Re: EA7300 loses internet connection but only on wifi

 

I replaced previous routers with the EA7300 and have seen the problem on my cellphone on both 2.4 & 5.0 GHz since the day I installed it.  I will be using it and it just drops out, even when the cellphone says it still attached to the wifi.  I usually just stop & start the wifi on the cellphone & it picks up again.  It has happens when I am 5 ft. away from the router.  I have not seen this same behavior on any of my other wifi devices, 

 

I can see about 30 wifi signals from my apartment, on both 2.4 & 5.0 GHz.  I have noticed that when I change channels, it seems to change other signals with it.

 

I also have the repeater wifi device.

 

Posts: 4
Registered: ‎12-06-2017

Re: EA7300 loses internet connection but only on wifi

Same here, my wife noticed that our phones were connected but no internet connection, She turn off and on, the wifi and worked again.

 

With all the same symptoms with the same equipment, why Linksys doesn't say anything? Or even a message telling us: We are aware, wait for a patch/update/fix. ? Silence just alienate the customers and loyalist with the brand.

 

The good news is : The next week is Christmas week, I bet that some very good deals will be available and we can try new routers and just trash our 7300.

 

 

Posts: 5
Registered: ‎11-29-2017

Re: EA7300 loses internet connection but only on wifi

I agree, it would be nice for some response here - apparently they don't watch their own forums?  A company that makes a trash product that they won't support, is no company I will do business with again.  Sooner or later I will replace this piece of S, and at that point Linksys will be dead to me.