Reply
Highlighted
Posts: 7
Registered: ‎11-17-2017
Accepted Solution

Need to disable IPv6 DNS server from the router

Folks,

 

This is related to my another post 

 

  https://community.linksys.com/t5/Wireless-Routers/Need-to-get-rid-of-quot-DNS-Suffix-Search-List-quo...

 

however, I think this is a separate issue. Please forgive me is this is an OP.

 

Basically, I'm having my own ipv4 DHCP & DNS server for my LAN. But the Linksys router insists on inserting itself as IPv6 DNS server. This actually creates problems for me bacause Windows 10 (or maybe earlier) has preference to IPv6.

 

IPConfig.png

 

So I wonder if there's a way to completely disable the router from inserting itself as IPv6 DNS server?

 

Workaround

 

Currently, I'm disabling Ipv6 from Windows client. Microsoft has several quick fixes for you to adjust IPv4 or IPv6 preference:

 

   https://support.microsoft.com/en-us/help/929852/how-to-disable-ipv6-or-its-components-in-windows

 

But I still think this should be disabled directly from the router.

 

Posts: 85
Registered: ‎06-07-2016

Re: Need to disable IPv6 DNS server from the router

Have you disabled IPv6 on the router? 

Posts: 7
Registered: ‎11-17-2017

Re: Need to disable IPv6 DNS server from the router

>> Have you disabled IPv6 on the router? 

 

Yes, I did disable ipv6. But the DNS entry is still there. Just to make sure, I follow the link below to diable ipv6:

 

   https://www.linksys.com/us/support-article?articleNum=140835

 

Thanks.

Expert
Posts: 13,339
Registered: ‎01-18-2013

Re: Need to disable IPv6 DNS server from the router

Are you sure you disabled IPv6 in your network DHCP Server?


Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Posts: 7
Registered: ‎11-17-2017

Re: Need to disable IPv6 DNS server from the router

Yes. I simply ise isc-dhcp-server without IPv6 capability. Afer play around the router settings I did find a better workaround. Instead of disabling the IPv6 on router, I now switch to "pass-through"

 

DisableIPv6.png

 

Now everything works fine. My guess is that Linksys router is too smart, so setting it to "pass-through" means don't mess around with IPv6, which solves the problem magically for now.

 

Will keep eyes on the corner cases to see if everything works as it is. Thx.