Reply
Highlighted
Posts: 14
Registered: ‎12-28-2017
Accepted Solution

Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

I bought a WRT3200ACM and installed DD WRT on it, thinking it'd function properly. Unfortunately, it gave a lot of issues with Wifi and crashing. The goal was to have a router with 2 SSIDs: one that goes through VPN, the other not.

 

Seeing the issues I faced, I wanted then to go back to stock firmware. I tried several things, ending up trying to load the factory firmware via TFTP + U boot (with a TTL cable). I'm now stuck in U-boot with a Bad data CRC error.

 

Here is how the boot goes:

 

BootROM - 1.73
Booting from NAND flash

General initialization - Version: 1.0.0
AVS selection from EFUSE disabled (Skip reading EFUSE values)
mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed
Detected Device ID 6820
High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3
Serdes Lane 4 is SGMII
board SerDes lanes topology details:
 | Lane # | Speed|    Type     |
 ------------------------------|
 |   0    |  6   |  SATA0      |
 |   1    |  5   |  PCIe0      |
 |   2    |  6   |  SATA1      |
 |   3    |  5   |  USB3 HOST1 |
 |   4    |  5   |  PCIe1      |
 |   5    |  0   |  SGMII2     |
 -------------------------------
:** Link is Gen1, check the EP capability 
PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities 
:** Link is Gen1, check the EP capability 
PCIe, Idx 1: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.46.0
mvSysEnvGetTopologyUpdateInfo: TWSI Read failed
DDR3 Training Sequence - Switching XBAR Window to FastPath Window 
DDR3 Training Sequence - Ended Successfully
Not detected suspend to RAM indication
BootROM: Image checksum verification PASSED

 __   __                      _ _
|  \/  | __ _ _ ____   _____| | |
| |\/| |/ _` | '__\ \ / / _ \ | |
| |  | | (_| | |   \ V /  __/ | |
|_|  |_|\__,_|_|    \_/ \___|_|_|
         _   _     ____              _
        | | | |   | __ )  ___   ___ | |_ 
        | | | |___|  _ \ / _ \ / _ \| __| 
        | |_| |___| |_) | (_) | (_) | |_ 
         \___/    |____/ \___/ \___/ \__| 
 ** LOADER **


U-Boot 2013.01 (Apr 08 2016 - 15:47:50) Marvell version: 2015_T1.QA.0p16

Boot version : v0.0.4

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0
DEVINFO offset == 0x7e0000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
S-ENV offset == 0x220000


#### auto_recovery ####
[u_env] get auto_recovery == yes
[u_env] get auto_recovery == yes
[u_env] get boot_part == 2
[u_env] get boot_part_ready == 3
auto_recovery enabled:1, boot_part:2, boot_part_ready:3 

S-ENV offset == 0x220000
[boot_count_read] block:0x220000, size:128KB, records:64 
[boot_count_read_record] boot_count:1, next_record:63

[boot_count_write] erase:1, auto_recovery->block_offset:0x220000 offset=0x220000

Updating boot_count ... 
[boot_count_write] offset:0x220000 , length:2048
done

PCI-e 0 (IF 0 - bus 0) Root Complex Interface, Detected Link X1, GEN 2.0
PCI-e 1 (IF 1 - bus 1) Root Complex Interface, Detected Link X1, GEN 1.1
USB2.0 0: Host Mode
USB3.0 1: Host Mode
USB3.0 0: Host Mode

Map:   Code:			0x1feab000:0x1ff75a20
       BSS:			0x1ffef164
       Stack:			0x1f9aaf20
       Heap:			0x1f9ab000:0x1feab000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
       U-Boot Environment:	0x00200000:0x00220000 (NAND)

Board configuration detected:
mvEthE6171SwitchBasicInit init 
Net:   
|  port  | Interface | PHY address  |
|--------|-----------|--------------|
| egiga0 |   RGMII   |     0x01     |
| egiga1 |   SGMII   |     0x00     |
| egiga2 |   SGMII   |   In-Band    |
egiga0 [PRIME], egiga1, egiga2
auto_recovery_check changes bootcmd: run altnandboot 
Hit any key to stop autoboot:  0 

NAND read: device 0 offset 0x5a00000, size 0x600000
 6291456 bytes read: OK
## Booting kernel from Legacy Image at 02000000 ...
   Image Name:   Linksys WRT3200 Router
   Created:      2016-10-18   2:10:32 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4640371 Bytes = 4.4 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!

 Can anyone help?

 

 

Expert
Posts: 14,167
Registered: ‎01-18-2013

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

What commands did you use to load the firmware via u-boot?

 

What was displayed during TFTP load "T" or "#"?


Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Posts: 14
Registered: ‎12-28-2017

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

# (took me a while to setup the right ip addresses etc but it finally worked). I used run update_both_images. Then reset.
Posts: 14
Registered: ‎12-28-2017

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

I also tried several images/bin files in the hope to revive le router after I failed with the Linksys firmware. No luck with any of them.
Expert
Posts: 14,167
Registered: ‎01-18-2013

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

Please post u-boot output for:

 

printenv nandboot
printenv altnandboot
printenv mtdparts
printenv priKernAddr
printenv priKernSize
printenv altKernAddr
printenv altKernSize
printenv ipaddr
printenv serverip
printenv firmwareName
printenv update_both_images

Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Posts: 14
Registered: ‎12-28-2017

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

[ Edited ]

Here it is:

BootROM - 1.73
Booting from NAND flash

General initialization - Version: 1.0.0
AVS selection from EFUSE disabled (Skip reading EFUSE values)
mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed
Detected Device ID 6820
High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3
Serdes Lane 4 is SGMII
board SerDes lanes topology details:
 | Lane # | Speed|    Type     |
 ------------------------------|
 |   0    |  6   |  SATA0      |
 |   1    |  5   |  PCIe0      |
 |   2    |  6   |  SATA1      |
 |   3    |  5   |  USB3 HOST1 |
 |   4    |  5   |  PCIe1      |
 |   5    |  0   |  SGMII2     |
 -------------------------------
:** Link is Gen1, check the EP capability 
PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities 
:** Link is Gen1, check the EP capability 
PCIe, Idx 1: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.46.0
mvSysEnvGetTopologyUpdateInfo: TWSI Read failed
DDR3 Training Sequence - Switching XBAR Window to FastPath Window 
DDR3 Training Sequence - Ended Successfully
Not detected suspend to RAM indication
BootROM: Image checksum verification PASSED

 __   __                      _ _
|  \/  | __ _ _ ____   _____| | |
| |\/| |/ _` | '__\ \ / / _ \ | |
| |  | | (_| | |   \ V /  __/ | |
|_|  |_|\__,_|_|    \_/ \___|_|_|
         _   _     ____              _
        | | | |   | __ )  ___   ___ | |_ 
        | | | |___|  _ \ / _ \ / _ \| __| 
        | |_| |___| |_) | (_) | (_) | |_ 
         \___/    |____/ \___/ \___/ \__| 
 ** LOADER **


U-Boot 2013.01 (Apr 08 2016 - 15:47:50) Marvell version: 2015_T1.QA.0p16

Boot version : v0.0.4

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0
DEVINFO offset == 0x7e0000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
S-ENV offset == 0x220000


#### auto_recovery ####
[u_env] get auto_recovery == yes
[u_env] get auto_recovery == yes
[u_env] get boot_part == 1
[u_env] get boot_part_ready == 3
auto_recovery enabled:1, boot_part:1, boot_part_ready:3 

S-ENV offset == 0x220000
[boot_count_read] block:0x220000, size:128KB, records:64 
[boot_count_read_record] boot_count:2, next_record:4

[boot_count_write] erase:0, auto_recovery->block_offset:0x220000 offset=0x222000

Updating boot_count ... 
[boot_count_write] offset:0x222000 , length:2048
done

PCI-e 0 (IF 0 - bus 0) Root Complex Interface, Detected Link X1, GEN 2.0
PCI-e 1 (IF 1 - bus 1) Root Complex Interface, Detected Link X1, GEN 1.1
USB2.0 0: Host Mode
USB3.0 1: Host Mode
USB3.0 0: Host Mode

Map:   Code:			0x1feab000:0x1ff75a20
       BSS:			0x1ffef164
       Stack:			0x1f9aaf20
       Heap:			0x1f9ab000:0x1feab000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
       U-Boot Environment:	0x00200000:0x00220000 (NAND)

Board configuration detected:
mvEthE6171SwitchBasicInit init 
Net:   
|  port  | Interface | PHY address  |
|--------|-----------|--------------|
| egiga0 |   RGMII   |     0x01     |
| egiga1 |   SGMII   |     0x00     |
| egiga2 |   SGMII   |   In-Band    |
egiga0 [PRIME], egiga1, egiga2
auto_recovery_check changes bootcmd: run nandboot 
Hit any key to stop autoboot:  0 

NAND read: device 0 offset 0xa00000, size 0x600000
 6291456 bytes read: OK
## Booting kernel from Legacy Image at 02000000 ...
   Image Name:   Linksys WRT3200 Router
   Created:      2016-10-18   2:10:32 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4640371 Bytes = 4.4 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!
Marvell>> printenv nandboot
nandboot=setenv bootargs console=ttyS0,115200 root=/dev/mtdblock6 ro rootdelay=1 rootfstype=jffs2 earlyprintk $mtdparts;nand read $defaultLoadAddr $priKernAddr $priKernSize; bootm $defaultLoadAddr
Marvell>> printenv altnandboot
altnandboot=setenv bootargs console=ttyS0,115200 root=/dev/mtdblock8 ro rootdelay=1 rootfstype=jffs2 earlyprintk $mtdparts;nand read $defaultLoadAddr $altKernAddr $altKernSize; bootm $defaultLoadAddr
Marvell>> printenv mtdparts
mtdparts='mtdparts=armada-nand:8m(boot)ro,8m@8m(kernel),-(rootfs);spi1.0:4m(boot),-(spi-rootfs);pxa3xx_nand-0:8m(boot)ro,8m@8m(kernel),-(rootfs)'
Marvell>> printenv priKernAddr
priKernAddr=0x0a00000
Marvell>> printenv priKernSize
priKernSize=0x0600000
Marvell>> printenv altKernAddr
altKernAddr=0x5a00000
Marvell>> printenv altKernSize
altKernSize=0x0600000
Marvell>> printenv ipaddr
ipaddr=192.168.1.126
Marvell>> printenv serverip
serverip=192.168.1.250
Marvell>> printenv firmwareName
firmwareName=rango.img
Marvell>> printenv update_both_images
update_both_images=tftpboot $defaultLoadAddr $firmwareName && nand erase $priKernAddr $priFwSize && nand erase $altKernAddr $altFwSize && nand write $defaultLoadAddr $priKernAddr $filesize && nand write $defaultLoadAddr $altKernAddr $filesize

And here is the result of update_both_images. I used the firmware FW_WRT3200ACM_1.0.6.181063_prod.img:

Marvell>> run update_both_images
Using egiga0 device
TFTP from server 192.168.1.250; our IP address is 192.168.1.126
Filename 'rango.img'.
Load address: 0x2000000
Loading: #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #######################################################################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 ############################################################
	 1.3 MiB/s
done
Bytes transferred = 41178848 (27456e0 hex)

NAND erase: device 0 offset 0xa00000, size 0x5000000
Erasing at 0x59e0000 -- 100% complete.
OK

NAND erase: device 0 offset 0x5a00000, size 0x5000000
Erasing at 0xa9e0000 -- 100% complete.
OK

NAND write: device 0 offset 0xa00000, size 0x27456e0
 41178848 bytes written: OK

NAND write: device 0 offset 0x5a00000, size 0x27456e0
 41178848 bytes written: OK
Marvell>> 
Expert
Posts: 14,167
Registered: ‎01-18-2013

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

I will confirm the envars and get back to you but it looks good according to my memory.

You may have a bad firmware file. I recommend you find a copy or download again.

Instead of renaming the file to rango.img you can use the below command to specify the filename.

setenv firmwareName FW_WRT3200ACM_1.0.6.181063_prod.img

Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Posts: 14
Registered: ‎12-28-2017

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

[ Edited ]

Thanks, I tried that already, re-downloaded it at least 3 times. No luck there. I tried renaming it too. Didn't make a difference unfortunately.

Expert
Posts: 14,167
Registered: ‎01-18-2013

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC


x5seb9x wrote:

Thanks, I tried that already, re-downloaded it at least 3 times. No luck there. I tried renaming it too. Didn't make a difference unfortunately.


Ok I see a problem with your mtdparts envar.

 

Please run the below command and reload the firmware:

 

setenv mtdparts 'mtdparts=armada-nand:2048K(uboot)ro,128K(u_env),256K(s_env),256K@8064K(devinfo),1920K@8320K(sysdiag),80m@10m(kernel),74m@16m(rootfs),80m@90m(alt_kernel),74m@96m(alt_rootfs),160m@10m(ubifs),-@170m(syscfg)'
saveenv
reset

Smiley Wink Please remember to Kudo those that help you.

Linksys
Communities Technical Support
Posts: 14
Registered: ‎12-28-2017

Re: Trying to get back to stock firmware with WRT3200ACM: Bad Data CRC

:/ unfortunately, that didn't work. Here is what I did (maybe I did something wrong?):

1. command you gave me

2. reset

3. Update both images

4. saveenv + reset to see if the boot works... fail.

 

See script here:

Marvell>> setenv mtdparts 'mtdparts=armada-nand:2048K(uboot)ro,128K(u_env),256K(s_env),256K@8064K(devinfo),1920K@8320K(sysdiag),80m@10m(kernel),74m@16m(rootfs),80m@90m(alt_kernel),74m@96m(alt_rootfs),160m@10m(ubifs),-@170m(syscfg)'
Marvell>> saveenv
Saving Environment to NAND...
U-ENV offset == 0x200000
Erasing Nand...
Writing to Nand... U-ENV offset == 0x200000
U-ENV offset == 0x200000
done
Marvell>> reset
resetting ...

BootROM - 1.73
Booting from NAND flash

General initialization - Version: 1.0.0
AVS selection from EFUSE disabled (Skip reading EFUSE values)
mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed
Detected Device ID 6820
High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3
Serdes Lane 4 is SGMII
board SerDes lanes topology details:
 | Lane # | Speed|    Type     |
 ------------------------------|
 |   0    |  6   |  SATA0      |
 |   1    |  5   |  PCIe0      |
 |   2    |  6   |  SATA1      |
 |   3    |  5   |  USB3 HOST1 |
 |   4    |  5   |  PCIe1      |
 |   5    |  0   |  SGMII2     |
 -------------------------------
:** Link is Gen1, check the EP capability 
PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities 
:** Link is Gen1, check the EP capability 
PCIe, Idx 1: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.46.0
mvSysEnvGetTopologyUpdateInfo: TWSI Read failed
DDR3 Training Sequence - Switching XBAR Window to FastPath Window 
DDR3 Training Sequence - Ended Successfully
Not detected suspend to RAM indication
BootROM: Image checksum verification PASSED

 __   __                      _ _
|  \/  | __ _ _ ____   _____| | |
| |\/| |/ _` | '__\ \ / / _ \ | |
| |  | | (_| | |   \ V /  __/ | |
|_|  |_|\__,_|_|    \_/ \___|_|_|
         _   _     ____              _
        | | | |   | __ )  ___   ___ | |_ 
        | | | |___|  _ \ / _ \ / _ \| __| 
        | |_| |___| |_) | (_) | (_) | |_ 
         \___/    |____/ \___/ \___/ \__| 
 ** LOADER **


U-Boot 2013.01 (Apr 08 2016 - 15:47:50) Marvell version: 2015_T1.QA.0p16

Boot version : v0.0.4

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0
DEVINFO offset == 0x7e0000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
S-ENV offset == 0x220000


#### auto_recovery ####
[u_env] get auto_recovery == yes
[u_env] get auto_recovery == yes
[u_env] get boot_part == 2
[u_env] get boot_part_ready == 3
auto_recovery enabled:1, boot_part:2, boot_part_ready:3 

S-ENV offset == 0x220000
[boot_count_read] block:0x220000, size:128KB, records:64 
[boot_count_read_record] boot_count:2, next_record:7

[boot_count_write] erase:0, auto_recovery->block_offset:0x220000 offset=0x223800

Updating boot_count ... 
[boot_count_write] offset:0x223800 , length:2048
done

PCI-e 0 (IF 0 - bus 0) Root Complex Interface, Detected Link X1, GEN 2.0
PCI-e 1 (IF 1 - bus 1) Root Complex Interface, Detected Link X1, GEN 1.1
USB2.0 0: Host Mode
USB3.0 1: Host Mode
USB3.0 0: Host Mode

Map:   Code:			0x1feab000:0x1ff75a20
       BSS:			0x1ffef164
       Stack:			0x1f9aaf20
       Heap:			0x1f9ab000:0x1feab000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
       U-Boot Environment:	0x00200000:0x00220000 (NAND)

Board configuration detected:
mvEthE6171SwitchBasicInit init 
Net:   
|  port  | Interface | PHY address  |
|--------|-----------|--------------|
| egiga0 |   RGMII   |     0x01     |
| egiga1 |   SGMII   |     0x00     |
| egiga2 |   SGMII   |   In-Band    |
egiga0 [PRIME], egiga1, egiga2
auto_recovery_check changes bootcmd: run altnandboot 
Hit any key to stop autoboot:  0 
Marvell>> run update_both_images
Using egiga0 device
TFTP from server 192.168.1.250; our IP address is 192.168.1.126
Filename 'rango.img'.
Load address: 0x2000000
Loading: #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #######################################################################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 #################################################################
	 ############################################################
	 1.3 MiB/s
done
Bytes transferred = 41178848 (27456e0 hex)

NAND erase: device 0 offset 0xa00000, size 0x5000000
Erasing at 0x59e0000 -- 100% complete.
OK

NAND erase: device 0 offset 0x5a00000, size 0x5000000
Erasing at 0xa9e0000 -- 100% complete.
OK

NAND write: device 0 offset 0xa00000, size 0x27456e0
 41178848 bytes written: OK

NAND write: device 0 offset 0x5a00000, size 0x27456e0
 41178848 bytes written: OK
Marvell>> saveenv
Saving Environment to NAND...
U-ENV offset == 0x200000
Erasing Nand...
Writing to Nand... U-ENV offset == 0x200000
U-ENV offset == 0x200000
done
Marvell>> reset
resetting ...

BootROM - 1.73
Booting from NAND flash

General initialization - Version: 1.0.0
AVS selection from EFUSE disabled (Skip reading EFUSE values)
mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed
Detected Device ID 6820
High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3
Serdes Lane 4 is SGMII
board SerDes lanes topology details:
 | Lane # | Speed|    Type     |
 ------------------------------|
 |   0    |  6   |  SATA0      |
 |   1    |  5   |  PCIe0      |
 |   2    |  6   |  SATA1      |
 |   3    |  5   |  USB3 HOST1 |
 |   4    |  5   |  PCIe1      |
 |   5    |  0   |  SGMII2     |
 -------------------------------
:** Link is Gen1, check the EP capability 
PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities 
:** Link is Gen1, check the EP capability 
PCIe, Idx 1: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.46.0
mvSysEnvGetTopologyUpdateInfo: TWSI Read failed
DDR3 Training Sequence - Switching XBAR Window to FastPath Window 
DDR3 Training Sequence - Ended Successfully
Not detected suspend to RAM indication
BootROM: Image checksum verification PASSED

 __   __                      _ _
|  \/  | __ _ _ ____   _____| | |
| |\/| |/ _` | '__\ \ / / _ \ | |
| |  | | (_| | |   \ V /  __/ | |
|_|  |_|\__,_|_|    \_/ \___|_|_|
         _   _     ____              _
        | | | |   | __ )  ___   ___ | |_ 
        | | | |___|  _ \ / _ \ / _ \| __| 
        | |_| |___| |_) | (_) | (_) | |_ 
         \___/    |____/ \___/ \___/ \__| 
 ** LOADER **


U-Boot 2013.01 (Apr 08 2016 - 15:47:50) Marvell version: 2015_T1.QA.0p16

Boot version : v0.0.4

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0
DEVINFO offset == 0x7e0000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
S-ENV offset == 0x220000


#### auto_recovery ####
[u_env] get auto_recovery == yes
[u_env] get auto_recovery == yes
[u_env] get boot_part == 2
[u_env] get boot_part_ready == 3
auto_recovery enabled:1, boot_part:2, boot_part_ready:3 

S-ENV offset == 0x220000
[boot_count_read] block:0x220000, size:128KB, records:64 
[boot_count_read_record] boot_count:3, next_record:8

[auto_recovery_init] BOOT_COUNT_TO_RECOVERY 
[boot_count_write] erase:0, auto_recovery->block_offset:0x220000 offset=0x224000

Updating boot_count ... 
[boot_count_write] offset:0x224000 , length:2048
done

PCI-e 0 (IF 0 - bus 0) Root Complex Interface, Detected Link X1, GEN 2.0
PCI-e 1 (IF 1 - bus 1) Root Complex Interface, Detected Link X1, GEN 1.1
USB2.0 0: Host Mode
USB3.0 1: Host Mode
USB3.0 0: Host Mode

Map:   Code:			0x1feab000:0x1ff75a20
       BSS:			0x1ffef164
       Stack:			0x1f9aaf20
       Heap:			0x1f9ab000:0x1feab000
U-ENV offset == 0x200000
U-ENV offset == 0x200000
       U-Boot Environment:	0x00200000:0x00220000 (NAND)

Board configuration detected:
mvEthE6171SwitchBasicInit init 
Net:   
|  port  | Interface | PHY address  |
|--------|-----------|--------------|
| egiga0 |   RGMII   |     0x01     |
| egiga1 |   SGMII   |     0x00     |
| egiga2 |   SGMII   |   In-Band    |
egiga0 [PRIME], egiga1, egiga2
Saving Environment to NAND...
U-ENV offset == 0x200000
Erasing Nand...
Writing to Nand... U-ENV offset == 0x200000
U-ENV offset == 0x200000
done
#### auto_recovery:1 ####
auto_recovery_check changes bootcmd: run nandboot 
Hit any key to stop autoboot:  0 

NAND read: device 0 offset 0xa00000, size 0x600000
 6291456 bytes read: OK
## Booting kernel from Legacy Image at 02000000 ...
   Image Name:   Linksys WRT3200 Router
   Created:      2016-10-18   2:10:32 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4640371 Bytes = 4.4 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!