Reply
Highlighted
Posts: 5
Registered: ‎11-09-2006
Accepted Solution

WRT 1900AC - Can't setup

So I finally unboxed a WRT 1900AC I got refurbished from Linksys a few months ago. After plugging it in and connecting the internet cable I tried connecting to the wireless network named on the sticker inside the quick guide. I can't.

 

I assume the SSID is not broadcast but I've entered in the info, deleted my home network, and my laptop won't connect. I saw a different linksys SSID so I tried logging on to that, but that didn't work, but that was the first time I saw the 2.4 light on my router light up.

 

I did a full reset (holding down the button for 30 seconds) and I'm sure I'm missing something very easy, but any help would be appreciated.

 

Thanks!

Posts: 103
Registered: ‎12-31-2017

Re: WRT 1900AC - Can't setup

[ Edited ]

Hi, I setup mine from my android phone without the app. When you attach to the router from the available names on the list, it will be named linksysxxxx (xxxx are the number assigned) it will ask for the password. Under the router their is a sticker with the password. Once you type in the password, you can connect. 

 

I recommend changing the password in wireless settings. Once done download the firmware update from linksys, as the router will not detect it. Once downloaded, you can apply the update manually, by going into connection, and selecting manual update. It will allow you to open the folder for your downloads, for applying the update.

 

Once updated, setup your router. Mine corrupted it's settings after a few setup changes and reboots, before applying the update. It was noticeable with dropping 5ghz connection after applying changes. Once I updated, the issues went away, and has been solid. 

Posts: 5
Registered: ‎11-09-2006

Re: WRT 1900AC - Can't setup

The best! The quick start has a big sticker with a totally different SSID and password from the sticker under the router! I guess its due to the refurb process. Haha. Thanks!